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Chapter 1 - Introduction 

About Navicat 

Navicat is a multi-connections Database Administration tool allowing you to connect to MySQL, Oracle, PostgreSQL, 

SQLite and/or MariaDB databases, making database administration to multiple kinds of database so easy. It also can 

manage cloud databases such as Amazon Redshift, Amazon RDS, Alibaba Cloud. Features in Navicat are 

sophisticated enough to provide professional developers for all their specific needs, yet easy to learn for users who are 

new to database server. With its well-designed Graphical User Interface(GUI), Navicat lets you quickly and easily 

create, organize, access and share information in a secure and easy way. 

Navicat is available on three platforms - Microsoft Windows, macOS and Linux. It can connect to local/remote servers, 

providing several utility tools such as Navicat Cloud Collaboration, Data Modeling, Data Transfer, Data/Structure 

Synchronization, Import/Export, Backup/Restore and Automation. 

For details, visit our website: https://www.navicat.com 

System Requirements 

Windows 

 Microsoft Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, Server 2008, Server 2012, 

Server 2016 

macOS 

 Mac OS X 10.10 Yosemite, Mac OS X 10.11 El Capitan, macOS 10.12 Sierra, macOS 10.13 High Sierra 

Linux 

 Ubuntu 12.04, Ubuntu 14.04, CentOS 6.7, CentOS 7, Fedora 22, Fedora 23, Linux Mint 13, Linux Mint 17.3, 

openSUSE 13.2, openSUSE 42.1 

Supported On-Premises Databases 

 MySQL 3.23 or above, Drizzle, OurDelta, Percona Server 

 PostgreSQL 7.3 or above 

 Oracle 8i or above 

 SQLite 2 and 3 

 MariaDB 5.1 or above 

Supported Cloud Databases 

Amazon AWS 

https://www.navicat.com/
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 Amazon Redshift 

 Amazon Aurora for MySQL 

 Amazon Aurora for PostgreSQL 

 Amazon RDS for MySQL 

 Amazon RDS for PostgreSQL 

 Amazon RDS for Oracle 

 Amazon RDS for MariaDB 

Google Cloud 

 Google Cloud SQL for MySQL 

 Google Cloud SQL for PostgreSQL 

Oracle Cloud 

 Oracle Database Cloud Service 

 Oracle MySQL Cloud Service 

Microsoft Azure 

 Microsoft Azure Database for MySQL 

 Microsoft Azure Database for PostgreSQL 

Alibaba Cloud 

 Alibaba Cloud ApsaraDB for RDS (MySQL) 

 Alibaba Cloud ApsaraDB for RDS (PostgreSQL) 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Note: Installing Navicat does not include the server installation. You should download and install the server manually. 

For user who has been trying our unregistered version, just simply key in the Registration Key (16 digit) on the pop up 

Registration screen. 

Installation for Download Version 

1. Download Navicat Linux version. 
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2. Open the gzip file. 

3. Extract the file into anywhere you wish. 

4. Run the start_navicat file to start your Navicat. Please note that it would take a while for starting-up. 

5. A Registration screen will then pop up, key in the Registration Key (16 digit) and click Activate to online 

activate the key. 

Installation for CD Version 

1. Load the Navicat CD Installation disk into the CD-ROM drive. 

2. Open the gzip file. 

3. Extract the file into anywhere you wish. 

4. Run the start_navicat file to start your Navicat. Please note that it would take a while for starting-up. 

5. A Registration screen will then pop up, key in the Registration Key (16 digit) and click Activate to online 

activate the key. 

Migrate Navicat to new computer 

1. In Navicat, choose File -> Export Connections. The exported file (.ncx) contains all your connection settings. 

2. Backup the exported file (.ncx). 

3. In Navicat, choose Help -> Registration and click Deactivate to online deactivate the key. 

4. Uninstall Navicat from the existing computer. 

5. Re-install Navicat in the new computer. 

6. Open Navicat and choose File -> Import Connections in the new computer. 

When a new connection is being established, Navicat will create a subfolder under Settings Location. Most files are 

stored within this subfolder. To look for the path, right-click the connection and choose Edit Connection -> Advanced 

-> Settings Location. 

Moreover, all your saved profiles are stored under profiles. To look for the path, choose Tools -> Options -> File 

Locarions -> Profiles Location. 

Upgrade Navicat 

If you want to upgrade an installed copy of Navicat to the latest release, please choose Help -> Check For Updates to 

start the Updater. It will automatically check your installed version. If there is a new version, simply follow the steps in 

the Updater to upgrade your Navicat. It will replace your previous Navicat and your current settings will remain 

unchanged. 
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Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement  

Note: For the License Agreement of Navicat Cloud service, please click here. 

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN.  

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a 

natural person and not a corporation, company, partnership or association or other entity or organization (ii) the 

individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit 

organization or charity organization only. For purposes of this definition, "educational institution" means a 

public or private school, college, university and other post secondary educational establishment. A non-profit 

organization is an organization whose primary objective is to support an issue or matter of private interest or 

public concern for non-commercial purposes.  

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and 

evaluate the Software, only.  

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any.  

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in each case, 

supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials, 

and online or electronic documentation.  

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE 

("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of 

fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial 

period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The 

UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation.  

f. "Navicat Essentials" means a version of the Software, so identified, to be used for commercial purpose.  

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA:  

https://customer.navicat.com/
http://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the 

Software on a storage device, such as a network server, used only to install the Software on your other 

computers over an internal network, provided you have a license for each separate computer on which the 

Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not 

be shared, installed or used concurrently on different computers.  

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on 

which the Software is installed may make a second copy of the Software and install it on either a portable 

computer or a computer located at his or her home for his or her exclusive use, provided that:  

A. the second copy of the Software on the portable or home computer (i) is not used at the same time as 

the copy of the Software on the primary computer and (ii) is used by the primary user solely as allowed 

for such version or edition (such as for educational use only),  

B. the second copy of the Software is not installed or used after the time such user is no longer the 

primary user of the primary computer on which the Software is installed.  

c. In the event the Software is distributed along with other PremiumSoft software products as part of a suite of 

products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the 

products in the Studio, including the Software, may be separated for installation or use on more than one 

computer.  

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You must 

reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the 

Software. You may not sell or transfer any copy of the Software made for backup purposes.  

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time, 

upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full 

compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses 

related to such audit in addition to any other liabilities you may incur as a result of such non-compliance.  

f. Your license rights under this EULA are non-exclusive.  

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically 

transfer the Software from one computer to another or over a network.  

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form.  

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software.  

d. Other than with respect to a Trial / Demo Version, Non-commercial Lite Version or a Not For Resale Version of 

the Software, you may permanently transfer all of your rights under this EULA only as part of a sale or transfer, 

provided you retain no copies, you transfer all of the Software (including all component parts, the media and 

printed materials, any upgrades, this EULA, the serial numbers, and, if applicable, all other software products 

provided together with the Software), and the recipient agrees to the terms of this EULA. If the Software is an 

upgrade, any transfer must include all prior versions of the Software from which you are upgrading. If the copy 

of the Software is licensed as part of the whole Studio (as defined above), the Software shall be transferred 

only with and as part of the sale or transfer of the whole Studio, and not separately. You may retain no copies 

of the Software. You may not sell or transfer any Trial / Demo Version, Non-commercial Lite Version or Not For 

Resale Version of the Software.  



 11 

 

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the 

Software.  

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial 

purpose.  

g. Unless otherwise provided herein, you shall not  

A. in the aggregate, install or use more than one copy of the Trial / Demo Version and Non-commercial 

Lite Version of the Software,  

B. download the Trial / Demo Version and Non-commercial Lite Version of the Software under more than 

one username,  

C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of 

the Software for an aggregate period in excess of the trial period for one license to such Trial / Demo 

Version,  

D. disclose the results of software performance benchmarks obtained using the Trial / Demo Version or 

Non-commercial Lite Version to any third party without PremiumSoft prior written consent, or  

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining 

whether to purchase a license to a commercial or education version of the software; provided, however, 

notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo 

Version or Non-commercial Lite Version of the Software for any commercial training purpose.  

h. You may only use the Not for Resale Version of the Software to review and evaluate the Software.  

i. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for the 

server or computer on which the Software is to be installed.  

j. You may receive the Software in more than one platform but you shall only install or use one platform.  

k. You shall not use the Software to develop any application having the same primary function as the Software.  

l. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must 

destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA 

surviving any such termination).  

m. This program may include Oracle Instant Client (OCI). You agree that you shall  

1. not use of the Oracle Instant Client to the business operations;  

2. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual or 

entity;  

a. make the Programs available in any manner to any third party for use in the third party's 

business operations; and  

b. title to the Programs from passing to the end user or any other party;  

3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and one copy 

of each Program media;  

4. discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after 

termination of the Agreement;  

5. not pubish any results of benchmark tests run on the Programs;  
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6. comply fully with all relevant export laws and regulations of the United States and other applicable 

export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof, 

are exported, directly or indirectly, in violation of applicable laws;  

7. allow PremiumSoft to audit your use of the Oracle Instant Client;  

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or 

entity unless such transfer is pursuant to Section 3.  

5. Ownership 

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title 

and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and 

as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not 

specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its 

suppliers.  

6. LIMITED WARRANTY AND DISCLAIMER 

a. Except with respect to Trial / Demo Version, Non-commercial Lite Version and Not For Resale Version of the 

Software, PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by 

a copy of your receipt): the physical media on which the Software is furnished will be free from defects in 

materials and workmanship under normal use. The Software is provided "as is". PremiumSoft makes no 

warranties, express or implied, arising from course of dealing or usage of trade, or statutory, as to any matter 

whatsoever.  

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software. Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software are provided "as is".  

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version, 

Non-commercial Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other 

warranties and representations, whether express, implied, or otherwise, including the warranties of 

merchantability or fitness for a particular purpose. Also, there is no warranty of non-infringement and title or 

quiet enjoyment. PremiumSoft does not warrant that the Software is error-free or will operate without 

interruption. The Software is not designed, intended or licensed for use in hazardous environments requiring 

fail-safe controls, including without limitation, the design, construction, maintenance or operation of nuclear 

facilities, aircraft navigation or communication systems, air traffic control, and life support or weapons systems. 

PremiumSoft specifically disclaims any express or implied warranty of fitness for such purposes.  

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration 

to thirty (30) days from the date of delivery.  

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees 

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN.  
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7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access 

data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the 

Software and based on any theory of liability including breach of contract, breach of warranty, 

tort (including negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised 

of the possibility of such damages.  

8. Third Party Software 

The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software.  

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA.  

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any 

varying or additional terms contained in any purchase order or other written notification or document issued by you in 

relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of 

its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the 

breach. 

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will 

be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and 

effect.  

10. Basis of Bargain 

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the 

agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic 

basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of 

PremiumSoft's licensors.  

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License.  
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"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory, 

as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a particular purpose or 

non-infringement of third party rights are expressly excluded. 

12. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction 

and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you 

desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft 

CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and 

logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any 

trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the 

Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective 

trademarks.  
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Chapter 2 - User Interface 

Main Window 

The Main Window consists of several toolbars and panes for you to work on connections, database objects and 

advanced tools. 

 

 Main Toolbar 

The Main Toolbar allows you to access basic objects and features, such as connections, users, tables, backup, 

automation and more. To use small icons or hide the captions, right-click on the toolbar and disable Use Big Icons or 

Show Caption. 

 Navigation Pane 

The Navigation Pane is the basic way to navigate with connections, databases and database objects. If the Navigation 

Pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane from the menu bar. 

 Tab Bar 

The Tab Bar allows you to switch among the tabbed windows on the Object Pane. You can choose to always display 

pop-ups on a new tab, or to always display them in a new window. If you have multiple tabs open, you can use 

CTRL+TAB to easily switch to other tabs. See also Options. 

 Object Toolbar 

The Object Toolbar provides other controls that you can use to manipulate the objects. 

 Object Pane 
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The Object Pane displays a list of object such as tables, views, queries, and the tabbed window forms. Use the  

List,  Detail and  ER Diagram buttons to change the view of the Objects tab. 

 Information Pane 

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object 

dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information 

Pane -> Show Information Pane from the menu bar. 

 Status Bar 

The Status Bar displays the current window's status information. 

Navigation Pane 

The Navigation pane employs tree structure which allows you to take action upon the database and their objects 

through their pop-up menus quickly and easily. If the Show objects under schema in navigation pane option is 

checked at the Options window, all database objects are also displayed in the pane. To connect to a database or 

schema, simply double-click it in the pane. 

After logged in the Navicat Cloud feature, the Navigation pane will be divided into Navicat Cloud and My Connections 

sections. 

 

You can filter the tree by focusing the tree and type a search string. To show the opened objects only, choose View -> 

Navigation Pane -> Show Only Active Objects from the menu bar. 

If you want to hide the group structure in the Navigation pane, select View -> Navigation Pane -> Flatten Connection. 

If the Navigation pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane. 
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Object Pane 

In the Objects tab, you can use the  List,  Detail and  ER Diagram buttons to change the object view. 

If you want to hide the group structure in List view or Details view, select View -> Flatten Object List from the menu 

bar. 

List View 

By default, Navicat uses the List view. It only shows the names of objects. 

Detail View 

Detail view shows the name and several properties of objects in columns. To change the display columns of properties, 

select View -> Choose Columns from the menu bar and select display columns for different objects from the pop-up 

window. 

ER Diagram View (Available only in Non-Essentials Edition) 

Note: Only tables provide ER Diagram view. 

An ER diagram will be generated automatically if the selected database/schema contains tables. ER diagram files are 

stored under Settings Location. 

 

 Diagram Canvas 

Display table fields and relationships between tables in a database/schema graphically. You can add, edit or delete 

relations between tables, and also add or delete vertices on a relation line. 

Add a Foreign Key 

Click  from the bottom toolbar. Drag and drop a field from the child table to the parent table. 
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Edit or Delete a Foreign Key 

Right-click a relation line and select Design Foreign Key or Delete Foreign Key from the pop-up menu. 

Add or Delete a Vertex 

Select a relation line or a vertex. Press and hold the SHIFT key and click on the relation line or the vertex. 

Note: Double-click a table in the ER Diagram view will open the Table Designer, while double-click a table in the List or 

Detail view will open the Table Viewer. 

 Overview 

To zoom in or zoom out the selected area of the diagram, adjust the slider of the Overview. Same effect can be 

achieved with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel up] 

Zoom Out: [CTRL+-] or [CTRL+Mousewheel down] 

 Bottom Toolbar 

 Refresh 

Refresh the ER diagram. Choose Regenerate ER Diagram to regenerate the ER diagram with using auto layout 

feature. 

 Move Diagram 

Switch to hand mode for moving the diagram. Or, you can press and hold the SPACE key, then move the diagram. 

 New Relation 

Add a relation between two table fields. Click this button, and then drag and drop a field from the child table to the 

parent table. 

 Color 

Set the color of the selected tables or relations. 

Paper Size 

Select a paper size from the drop-down list. The corresponding paper size will reflect in the Overview. 

Information Pane 

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object 

dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information 

Pane -> Show Information Pane from the menu bar. 
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You can select any connections, objects or projects, and then select the corresponding buttons on the Information 

Pane. 

Button Description 

 

General - Show the general information of the object/project. 

 

Preview - Show the SQL statements in the query. 

 

DDL - Show the DDL statements of the object. 

 

Using - Show the objects that the selected object depends on. 

Objects - Show the objects in the tablespace. 

Member Of - Show the roles that the user or the role assigned to. 

 

Used By - Show the objects that depend on the selected object.  

Members - Show the members of the role. 

 

Code Snippet - Show all built-in and custom code snippets. 

(Available only in Non-Essentials Edition) 

 

Identifiers - Show all tables, views and columns in the selected database or schema. 

 

Project - Show the project members and the project activities done by the members. 

Click + to add members to the project. 
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Chapter 3 - Navicat Cloud 

About Navicat Cloud 

Navicat Cloud provides a cloud service for synchronizing connections, queries, model files and virtual group 

information from Navicat, other Navicat family members, different machines and different platforms. All the Navicat 

Cloud objects are located under different projects. You can share the project to other Navicat Cloud accounts for 

collaboration. 

Create a new account 

1. In the main window, click Sign In and click Create Navicat ID. 

2. Enter the required information and click the Sign Up button. A verification email will send to your email 

address. 

3. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign in Navicat Cloud 

1. In the main window, click Sign In and enter your Navicat ID and Password. 

2. Click the Sign In button. 

3. If you enabled two-step verification in Navicat Cloud Portal site, a code will be sent to your phone via your 

mobile app. Enter the received code to sign in. 

Sign out Navicat Cloud 

1. In the main window, right-click Navicat Cloud and choose Close All Connections to close all connections 

under Navicat Cloud. 

2. Click your avatar on the toolbar. 

3. Click your email in the Navicat Cloud window and choose Sign Out. 

Manage Navicat Cloud 

View the cloud usage 

1. In the main window, click your avatar on the toolbar. 

2. Your cloud usage and current plan will be shown in the Navicat Cloud window. 

Note: A connection, a query, a model or a virtual group counts for one unit. 

https://cloud.navicat.com/
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Change your avatar 

1. In the main window, click your avatar on the toolbar. 

2. Click the avatar in the Navicat Cloud window. 

3. Choose an image file. 

Manage your Navicat Cloud account 

1. In the main window, click your avatar on the toolbar. 

2. Click your email in the Navicat Cloud window and choose Manage Account. 

3. A browser will open with Navicat Cloud Portal site. 

Upgrade the Navicat Cloud plan 

1. In the main window, click your avatar on the toolbar. 

2. Click Upgrade in the Navicat Cloud window. 

3. A browser will open with Navicat Cloud Portal site. 

Create a project 

1. Select Navicat Cloud in the Navigation pane. 

2. Right-click it and choose New Project. 

Add members to a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Collaborate with. 

3. Click Add Members. 

4. Enter the members' Navicat ID. 

5. Select the member role. 

6. Click Add. 

Member Roles  Privileges 

Owner Read Objects, Write Objects, Manage Members and Delete Project 

Admin Read Objects, Write Objects and Manage Members 

Member Read Objects and Write Objects 

Guest Read Objects 

https://cloud.navicat.com/
https://cloud.navicat.com/
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Note: Each time can add up to 10 members. Use comma or enter to separate the members in the edit box. 

Manage members in a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Collaborate with. 

3. Click Apply after changes. 

Note: If you are the Owner or Admin, you can click the x button to remove the member. 

Rename a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Rename. 

3. Enter the project name. 

Quit a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Quit Project. 

Delete a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Delete Project. 

Move/copy a connection to a project 

1. Right-click a connection under My Connections and choose Move Connection to or Copy Connection to. 

2. Select an existing project or create a new project. 

3. The connection will move or copy to Navicat Cloud. And, all its query files and virtual groups will store in 

Navicat Cloud. 

Move/copy a connection to My Connections 

1. Right-click a connection under Navicat Cloud and choose Move Connection to or Copy Connection to -> 

My Connections. 

2. The connection will move or copy to My Connections. And, all its query files and virtual groups will store in the 

local machine. 

Move/copy a model to Navicat Cloud 
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1. Select a model file under My Connections. 

2. Drag and drop it to a project in Navicat Cloud. 

Move/copy a model to My Connections 

1. Select a model file in a project under Navicat Cloud. 

2. Drag and drop it to My Connections. 
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Chapter 4 - Connection 

About Connection 

To start working with your server in Navicat, you should first establish a connection or several connections using the 

Connection window. If you are new to the server or 'Net in general' and are not quite sure how things work, you may 

want to look at: 

 MySQL User Manual 

 Oracle Database Documentation 

 PostgreSQL User Manual 

 SQLite User Manual 

 MariaDB Documentation 

To create a new connection, click  Connection and select your server type. Then, enter the necessary information 

in the Connection window. 

Note: Navicat authorizes you to make connection to remote servers running on different platforms (i.e. Windows, 

macOS, Linux and UNIX), and supports PAM and GSSAPI authentication. 

You can edit the connection properties by right-click the connection and choose Edit Connection. 

Navicat Cloud 

To copy or move a connection between My Connections and Navicat Cloud, right-click the connection and choose 

Copy Connection to or Move Connection to. 

Flush MySQL/MariaDB Connection 

To clear or reload various internal caches, flush tables, or acquire locks, right-click your connection in the Navigation 

pane and select Flush and choose the flush option. You must have the RELOAD privilege to use this feature. 

Testing Account 

Navicat provides evaluated accounts for testing purpose. 

MySQL 

 Host: server1.navicat.com 

 Port: 4406 

 User Name: navicat 

http://dev.mysql.com/doc/
http://www.oracle.com/technology/documentation/index.html
http://www.postgresql.org/docs/manuals/
http://www.sqlite.org/docs.html
https://mariadb.com/kb/en/mariadb-documentation/
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 Password: testnavicat 

PostgreSQL 

 Host: server1.navicat.com 

 Port: 5432 

 Initial Database: HR 

 User Name: navicat 

 Password: testnavicat 

General Settings 

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database 

login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) / HTTP is another solution. 

Note: The following options depend on the connection server type and sort in ascending order. 

Add To 

After you logged in the Navicat Cloud feature, you can choose to save the connection to My Connections or a project in 

Navicat Cloud. 

Connection Name 

Enter a friendly name to best describe your connection. 

Connection Type 

Basic In Basic mode, it connects to Oracle through the Oracle Call Interface (OCI). Enter 

the Host and Port. Set the Service Name/SID which the user connects when 

making connection. Select the corresponding radio button. 

OCI is an application programming interface that allows an application developer to use a third-generation language's 

native procedure or function calls to access the Oracle database server and control all phases of SQL statement 

execution. OCI is a library of standard database access and retrieval functions in the form of a dynamic-link library. See 

also: OCI options 

Database File 

Specify the initial database file. If the HTTP Tunnel is enabled, you need to enter an absolute file path of the database 

file in your web server. 

Endpoint 
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The Endpoint for connecting to the Amazon Web Services instance. 

Host 

A host name where the database is situated or the IP address of the server. 

Initial Database 

Set the initial database which user connects when making connection. 

Password 

Password for connecting to the database server. 

Port 

A TCP/IP port for connecting to the database server. 

Sync User Name with Navicat Cloud 

When editing a connection in Navicat Cloud, you can choose to synchronize the user name. 

Type 

Existing Database File Connect to an existing database in the Database File. 

New SQLite 3 Create a new SQLite 3 database in the Database File. 

New SQLite 2 Create a new SQLite 2 database in the Database File. 

User Name 

User name for connecting to the database server. 

SSL Settings 

Secure Sockets Layer(SSL) is a protocol for transmitting private documents via the Internet. To get a secure 

connection, the first thing you need to do is to install OpenSSL Library and download Database Source. 

Note: Available only for MySQL, PostgreSQL and MariaDB. Support from PostgreSQL 8.4 or later. 

MySQL and MariaDB Connections 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Certificate 

The SSL certificate file in PEM format to use for establishing a secure connection. 
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CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Verify server certificate against CA 

Check the server's Common Name value in the certificate that the server sends to the client. 

Specified Cipher 

A list of permissible ciphers to use for SSL encryption. 

PostgreSQL Connection 

Choose the SSL Mode: 

require Only try an SSL connection. 

verify-ca Only try an SSL connection, and verify that the server certificate is issued by a 

trusted CA. 

verify-full Only try an SSL connection, verify that the server certificate is issued by a trusted 

CA and that the server hostname matches that in the certificate. 

To provide authentication details, enable Use authentication and fill in the required information: 

Client Key 

The path of the client private key. 

Client Certificate 

The path of the client certificate. 

Root Certificate 

The path of the trusted certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

SSH Settings 

Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote 

server, and move files from one machine to another. It provides strong authentication and secure encrypted 

communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network. 

Typically, it is employed as an encrypted version of Telnet. 

In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing 

anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to 
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session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent 

such vulnerabilities and allows you to access a remote server's shell without compromising security. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise, 

the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding 

should be enabled. Please double check the value settings. 

Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat cannot connect via SSH 

Port 22. 

Host 

A host where SSH server is activated. 

Note: The host name in the General tab should be set relatively to the SSH server which provided by your database 

hosting company. 

Port 

A port where SSH server is activated, by default it is 22. 

User Name 

A user on SSH server machine. (It is not a user of database server.) 

Sync User Name with Navicat Cloud 

When editing a connection in Navicat Cloud, you can choose to synchronize the user name. 

Authentication Method 

Password Provide the SSH server user Password. 

Public Key Private Key 

It is used together with your public key. The private key should be readable only by 

you. 

Passphrase 

A passphrase is exactly like a password, except that it applies to the keys you are 

generating and not an account. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 
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HTTP Settings 

HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80) 

as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP 

connections. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Uploading the Tunneling Script 

To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your 

server is located. 

Note: ntunnel_mysql.php (for both MySQL and MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php is available in 

the Navicat installation folder. 

Setting up HTTP Tunnel 

The following instruction guides you through the process of configuring a HTTP connection. 

1. Select the HTTP tab and enable Use HTTP tunnel. 

2. Enter URL of the tunneling script. 

e.g. http://www.navicat.com/ntunnel_mysql.php 

3. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64 

option. 

4. If the tunneling script is hosted in a password protected server or you have to access internet over a proxy 

server, you can provide the required authentication details in the Authentication or Proxy tab. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

Advanced Settings 

Note: The following options depend on the connection server type and sort in ascending order. 

Auto connect 

Open the connection at application startup automatically. 

Client Character Set 

Choose the session client character set used in Navicat. 

Encoding 
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Choose a codepage for converting data to display in Navicat UI. 

Encrypted 

Enable this option and provide Password when connecting to an encrypted SQLite database. 

Keepalive interval (sec) 

Keep the connection with the server alive by pinging it. You can set the period between pings in the edit box. 

Limit connection sessions 

Specify the maximum number of concurrent connections that the server allows. 

OS authentication 

Use OS user login credentials to authenticate database users. 

Role 

Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege. 

Settings Location 

When a new connection is being established, Navicat will create a subfolder under the Settings Location. Most files are 

stored within this subfolder: 

File in Settings Location Server Type File Extension 

Backup MySQL, PostgreSQL, SQLite and 

MariaDB 

.nb3 

Backup Profile MySQL .nbakmysql 

PostgreSQL .nbakpgsql 

SQLite .nbaksqlite 

MariaDB .nbakmysql 

Data Pump Export Profile Oracle .nbakora 

ER Diagram File All .ned 

Export Materialized View 

Profile 

Oracle .nexpmora 

PostgreSQL .nexpmpgsql 

Export Query Result Profile MySQL .nexpqmysql 

Oracle .nexpqora 

PostgreSQL .nexpqpgsql 

SQLite .nexpqsqlite 

MariaDB .nexpqmariadb 

Export Table Profile MySQL .nexptmysql 

Oracle .nexptora 

PostgreSQL .nexptpgsql 
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SQLite .nexptsqlite 

MariaDB .nexptmariadb 

Export View Result Profile MySQL .nexpvmysql 

Oracle .nexpvora 

PostgreSQL .nexpvpgsql 

SQLite .nexpvsqlite 

MariaDB .nexpvmariadb 

Import Table Profile MySQL .nimpmysql 

Oracle .nimpora 

PostgreSQL .nimppgsql 

SQLite .nimpsqlite 

MariaDB .nimpmariadb 

Query All .sql 

Use compression 

Use compression protocol. It is used if both client and server support zlib compression, and the client requests 

compression. 

Use named pipe, socket 

Use socket file for localhost connection. 

Databases / Attached Databases Settings 

MySQL, Oracle, PostgreSQL, MariaDB 

In the Databases tab, you can set which databases will be shown in the Navigation pane when connecting to your 

server. It is not obligatory. To start working with custom database settings, check Use custom database list. Then, 

select the preferable databases in the Database column. If you want Navicat automatically open the databases at 

connection, check the Auto Open box. 

Add a hidden database to the list 

1. Click the Add Database to List button. 

2. Enter the database name. 

3. Select the newly added database in the database list. 

Remove a database from the list 

1. Select the database in the database list. 

2. Click the Remove Database from List button. 

Note: The database will be just removed from the database list box, it will still exist in the server. 
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SQLite 

In the Attached Databases tab, you can attach SQLite database files to the connection. Click the Attach Database 

button and enter the information: 

Option Description 

Database File Choose the file path of a database file. 

Database Name Enter the database name which displays in Navicat. 

Encrypted Check this option and provide the Password if the database file is 

encrypted. 

To detach a database, select it from the list and click the Detach Database button.  
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Chapter 5 - Server Objects 

About Server Objects 

Navicat provides powerful tools to manage server objects, such as databases, tables, views, functions, etc. 

Note: Before working with the server objects in Navicat, you should establish the connection first. 

In object designers, you can preview the CREATE statement and the necessary SQL statements for creating/editing 

the object in the SQL Preview tab. For some database or schema objects, you can use the bottom drop-down list to 

show the SQL which will be run when choosing Save or Save As from the File menu. 

MySQL / MariaDB 

Databases 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database. 

Create a new database 

1. In the Navigation pane, right-click your connection and choose New Database. 

2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and choose Edit Database. 

2. Edit the database properties in the pop-up window. 

Note: MySQL does not support renaming database through its interface at this moment. Access the directory in which 

databases being stored. By default, all databases store within a directory called data under MySQL Installation folder. 

For example: /var/lib/mysql/. You must stop MySQL before you can rename the database. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

There are two ways to open a table with graphical fields, right-click a table and choose: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 
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To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. 

Note: The tabs and options in the designer depend on the server type and version. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Note: Transaction is only available for INNODB tables. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge 

of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

Note: Transaction is only available for updatable views. 
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Procedures / Functions 

Procedures and functions (stored routines) are supported in MySQL 5.0. A stored routine is a set of SQL statements 

that can be stored in the server. In the main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a 

procedure/function easily. 

1. Select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Mode, Name and/or Type under the corresponding columns. 

3. If you create a function, select the Return Type from the list and enter the corresponding information: Length, 

Decimals, Character set and/or Enum. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound 

statement written using BEGIN and END. Compound statements can contain declarations, loops, and other control 

structure statements. To customize the view of the editor and find out more features for SQL editing, see SQL Editor for 

details. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 

procedure/function requires input parameters, the Input Parameter dialog will pop up. Check the Raw Mode option to 

pass the inputted values to the procedure/function without quotation marks. 

Note: Navicat supports to return 10 result sets. 

Events 

An event is a task that run according to a schedule. In the main window, click  Event to open the event object list. 

Event Designer 

Event Designer is the basic Navicat tool for working with events. You can enter a valid SQL procedure statement in 

the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound statement 

written using BEGIN and END. Compound statements can contain declarations, loops, and other control structure 

statements. To customize the view of the editor and find out more features for SQL editing, see SQL Editor for details. 
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Maintain Objects 

Navicat provides a complete solution for maintaining MySQL / MariaDB objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Table 

Option Description 

Analyze Tables Analyze and store the key distribution for the table. 

Check Tables Check the table for errors. 

Optimize Tables Optimize the table to reduce storage space and improve I/O efficiency. 

Repair Tables Repair the possibly corrupted table. 

Get Rows Count Count the number of rows in the table. 

 

Oracle 

Schemas 

To start working with the server objects, you should create and open a connection. When you create a user account, 

you are also implicitly creating a schema for that user. A schema is a logical container for the database objects (such 

as tables, views, triggers, and so on) that the user creates. The schema name is the same as the user name, and can 

be used to unambiguously refer to objects owned by the user. 

Hint: Oracle interprets non-quoted object identifiers as uppercase. In Navicat, all object identifiers will be quoted. That 

is, Navicat saves exactly what you have inputted. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create Normal / External / Index Organized tables. Click the down arrow next to  New Table from the 

object toolbar and choose the table type. 

There are two ways to open a table with graphical fields, right-click a table and choose: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 
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down the SHIFT key when right-clicking the table.) 

To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version and the table type. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge 

of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

http://192.168.1.247/online_manual/en/navicat/win_manual/#/data_viewer
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Materialized Views 

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main 

window, click  Materialized View to open the materialized view object list. 

To refresh a materialized view, right-click it in the Objects tab and select Refresh Materialized View from the pop-up 

menu. 

Materialized View Designer 

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view 

definition as SQL statement (SELECT statement it implements) in the Definition tab. To customize the view of the 

editor and find out more features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a 

SQL file to the editor, you can choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the materialized view. 

 Explain Show the Query Plan of the materialized view. 

 View Builder Build the materialized view visually. It allows you to create and edit materialized 

views without knowledge of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Result -> 

Show Below Editor or Show in New Page. 

Materialized View Viewer 

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two 

modes: Grid View and Form View. See Data Viewer for details. 

Procedures / Functions 

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. In the 

main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a 

procedure/function easily. 

1. Specify the Name of the routine and select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Name, Type, Mode and Default Value under the corresponding columns. 

3. If you create a function, select the Return Type from the list. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 



 39 

 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. To customize the view of the editor and find out more features for SQL editing, see 

SQL Editor for details. 

The Code Outline pane displays information about the procedure/function including parameters, code body, etc. If the 

Code Outline pane is hidden, choose View -> Code Outline. 

Note: Available only in Non-Essentials Edition. 

Button Description 

 

Refresh the code outline. 

 

Show the detail view of the code outline. 

 

Turn mouse over highlight on or off. 

 

Expand the selected item. 

 

Collapse the selected item. 

 

Toggle sorting by position. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an 

error occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 

procedure/function requires input parameters, the Input Parameter dialog will pop ups. Check the Raw Mode option to 

pass the inputted values to the procedure/function without quotation marks. 

Note: Navicat supports to return 10 result sets. 

Debug (Available only in Non-Essentials Edition) 

You can add/remove breakpoints for debugging by clicking  in the grey area beside each statement. 

Before debugging, click  Save As Debug to save and compile the procedure/function. Then, click  Debug on 

the toolbar to launch the Oracle Debugger. Enter the input parameters if necessary. 

Packages 

Packages are encapsulated collections of related procedures, stored functions, and other program objects stored 

together in the database. An package consists of two parts: a specification and a body. In the main window, click  

Others -> Package to open the package object list. 

Package Designer & Package Body Designer 

Package Designer and Package Body Designer are the basic Navicat tools for working with packages. After saving 

the package in Package Designer, you can edit its package body by clicking  New Package Body or  Design 

Package Body. 
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Likewise, you can edit its package specification by clicking  Design Package Specification in Package Body 

Designer. 

You can enter a valid SQL statement in the Definition tab. To customize the view of the editor and find out more 

features for SQL editing, see SQL Editor for details. 

The Code Outline pane displays information about the package/package body including function, procedure, 

parameter, code body, etc. If the Code Outline pane is hidden, choose View -> Code Outline. 

Note: Available only in Non-Essentials Edition. 

Button Description 

 

Refresh the code outline. 

 

Show the detail view of the code outline. 

 

Turn mouse over highlight on or off. 

 

Expand the selected item. 

 

Collapse the selected item. 

 

Toggle sorting by position. 

Results 

To execute the package, click  Execute on the toolbar. If the SQL statement is correct, the statement will be 

executed and, if the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an 

error occurs while executing the package, execution stops, the appropriate error message is displayed. If the package 

requires input parameters, the Input Parameter dialog will pop up. 

Debug (Available only in Non-Essentials Edition) 

You can add/remove breakpoints for debugging by clicking  in the grey area beside each statement. 

Before debugging, click  Save As Debug to save and compile the package. Then, click  Debug on the toolbar 

to launch the Oracle Debugger. Enter the input parameters if necessary. 

Recycle Bin 

Recycle bin contains dropped tables and any associated objects such as indexes, constraints, nested tables. In the 

main window, click  Others -> Recycle Bin to open the recycle bin object list. 

Restore a table 

1. Select a table in the Objects tab. 

2. Click  Flashback Table. 

Remove an object 

1. Select an object for purging in the Objects tab. 
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2. Click  Purge Object. 

3. Confirm deleting in the dialog window. 

Remove all objects 

1. Right-click anywhere in the Objects tab and choose Purge Recycle Bin from the pop-up menu. 

2. Confirm deleting in the dialog window. 

Remove all objects of any users 

1. Log in a user with SYSDBA privilege. 

2. Right-click anywhere in the Objects tab and choose Purge DBA Recycle Bin from the pop-up menu. 

3. Confirm deleting in the dialog window. 

Other Objects 

Navicat also allows you to manage other Oracle objects: Database Link, Index, Java, Materialized View Log, Sequence, 

Synonym, Trigger, Type, XML Schema, Directory, Public Database Link, Public Synonym and Tablespace. In the main 

window, click  Others and select an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining Oracle objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Table 

Option Description 

Enable Table Lock Allow DDL operations on the table. 

Disable Table Lock Prevent DDL operations on the table. 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of rowid. 

Shrink Space Shrink space in the table. 

Move Relocate data of the table. 

Collect Statistics Analyze the contents of the table. 

Validate Structure Verify the integrity of the structure of the table. 

View 
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Option Description 

Compile Recompile the view specification or body. 

Procedure / Function 

Option Description 

Compile Recompile the specification or body. 

Compile for Debug Recompile the specification or body. Instruct the PL/SQL compiler to generate 

and store the code for use by the debugger. 

Index 

Option Description 

Rebuild Re-create the index or one of its partitions or subpartitions. 

Make Unusable Make the index unusable. 

Coalesce Merge the contents of index blocks where possible to free blocks for reuse. 

Compute Statistics Compute the statistics of the index. 

Monitoring Usage Begin monitoring the index. 

No Monitoring Usage Terminate monitoring the index. 

Java 

Option Description 

Compile or Resolve Resolve the primary Java class schema object. 

Set AuthID Current User Set the invoker rights to AUTHID CURRENT_USER. 

Set AuthID Definer Set the invoker rights to AUTHID DEFINER. 

Materialized View 

Option Description 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of rowid. 

Shrink Compact the materialized view segment. 

Compile Revalidate the materialized view. 

Force Refresh Fresh the materialized view. 

Materialized View Log 

Option Description 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of rowid. 

Shrink Space Compact the materialized view log segments. 

Package 

Option Description 

Compile Recompile the package specification and body. 
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Compile for Debug Recompile the package specification and body. Instruct the PL/SQL 

compiler to generate and store the code for use by the debugger. 

Trigger 

Option Description 

Enable Enable the trigger. 

Disable Disable the trigger. 

Compile Recompile the trigger. 

Compile for Debug Recompile the trigger. Instruct the PL/SQL compiler to generate and store the 

code for use by the debugger. 

Type 

Option Description 

Compile Recompile the type specification and body. 

Compile for Debug Recompile the type specification and body. Instruct the PL/SQL compiler to 

generate and store the code for use by the debugger. 

XML Schema 

Option Description 

Compile Recompile the already registered XML schema. 

Purge Removes the XML schema completely from Oracle XML DB. 

Tablespace 

Option Description 

Read Only Place the tablespace in transition read-only mode. 

Read Write Allow write operations on a previously read-only tablespace. 

Online Take the tablespace online. 

Offline Take the tablespace offline. 

Coalesce Combine all contiguous free extents into larger contiguous extents for each 

datafile in the tablespace. 

Shrink Space Reduce the amount of space the tablespace is taking. 

 

PostgreSQL 

Databases & Schemas 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database and/or a new schema. 

Create a new database 

1. In the Navigation pane, right-click a connection and choose New Database. 
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2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and choose Edit Database. 

2. Edit the database properties in the pop-up window. 

Create a new schema 

1. In the Navigation pane, right-click a database and choose New Schema. 

2. Enter the schema properties in the pop-up window. 

Edit an existing schema 

1. In the Navigation pane, right-click a schema and choose Edit Schema. 

2. Edit the schema properties in the pop-up window. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create Normal / Foreign tables. Click the down arrow next to  New Table from the object toolbar and 

choose the table type. 

There are two ways to open a table with graphical fields, right-click a table and choose: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 

To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version and the table type. 
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Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge of 

SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

Materialized Views 

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main 

window, click  Materialized View to open the materialized view object list. 

To refresh and completely replace the contents of a materialized view, right-click it in the Objects tab and select 

Refresh Materialized View With -> Data or No Data from the pop-up menu. 

Materialized View Designer 

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view 

definition as SQL statement (SELECT statement it implements) in the Definition tab. To customize the view of the 

editor and find out more features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a 

SQL file to the editor, you can choose File -> Import SQL. 
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Button Description 

 Preview Preview the data of the materialized view. 

 Explain Show the Query Plan of the materialized view. 

 View Builder Build the materialized view visually. It allows you to create and edit materialized 

views without knowledge of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Result -> 

Show Below Editor or Show in New Page. 

Materialized View Viewer 

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two 

modes: Grid View and Form View. See Data Viewer for details. 

Functions 

Functions are schema objects that consist a set of SQL statements and stored in the server. In the main window, click 

 Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a function 

easily. 

1. Define the parameters. Set the Mode, Type Schema, Type, Name and Default Value under the 

corresponding columns. 

2. Select the Schema and Return Type from the list. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with functions. You can enter a valid SQL statement in the 

Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound statement written 

using BEGIN and END. To customize the view of the editor and find out more features for SQL editing, see SQL Editor 

for details. 

Results 

To execute the function, click  Execute on the toolbar. If the SQL statement is correct, the statement will be 

executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the function, execution stops, the appropriate error message is displayed. If the function 

requires input parameters, the Input Parameter dialog will pop up. Check the Raw Mode option to pass the inputted 

values to the function without quotation marks. 

Note: Navicat supports to return 10 result sets. 
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Debug (Available only in Non-Essentials Edition) 

Before debugging PL/pgSQL functions, you need to install the pldbgapi extension. You can right-click anywhere in the 

function object list and select Install pldbgapi Extension. 

Note: This option is only available for PostgreSQL 9.1 or above. If your server is PostgreSQL 8.3 to 9.0, you need to 

enable the debugger plugin manually in the server. 

Then, open a PL/pgSQL function. You can add/remove breakpoints for debugging by clicking  in the grey area 

beside each statement. 

Click  Debug on the toolbar to launch the PostgreSQL Debugger. 

Types 

Types registers new data types for use in the current database. In the main window, click  Others -> Type to open 

the type object list. 

You can create Base / Composite / Enum / Range types. Click the down arrow next to  New Type from the object 

toolbar and choose the type. 

Type Designer 

Type Designer is the basic Navicat tool for working with types. It allows you to create or edit a type. 

Note: The tabs and options in the designer depend on the server version and the type you are chosen. 

Foreign Servers 

A foreign server typically encapsulates connection information that a foreign-data wrapper uses to access an external 

data resource. In the main window, click  Others -> Foreign Server to open the foreign server object list. 

To install the postgres_fdw extension for accessing data stored in external PostgreSQL servers, you can right-click 

anywhere in the foreign server object list and select Install postgres_fdw Extension. 

Foreign Server Designer 

Foreign Server Designer is the basic Navicat tool for working with foreign servers. It allows you to create or edit a 

foreign server. 

Other Objects 

Navicat also allows you to manage other PostgreSQL objects: Aggregate, Conversion, Domain, Index, Operator, 

Operator Class, Sequence, Trigger, Tablespace, Cast and Language. In the main window, click  Others and select 

an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining PostgreSQL objects. 
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1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Database 

Option Description 

Allow Users can connect to the database. 

Disallow No users can connect to the database. 

Analyze Database Collect statistics about the database. 

Vacuum Database Garbage-collect and optionally analyze the database. 

Reindex Database Recreate all indexes within the database. 

Table / Materialized View 

Option Description 

Analyze Tables / Analyze 

Materialized Views 

Collect statistics about the contents of the table. 

Vacuum Tables / Vacuum 

Materialized Views 

Garbage-collect and optionally analyze the table. 

Reindex Tables / Reindex 

Materialized Views 

Recreate all indexes of the table. 

SQLite 

Databases 

To start working with the server objects, you should create and open a connection. The database file set in the General 

tab of the Connection window is named as the main database. 

Attach a database file 

1. In the Navigation pane, right-click a connection and choose Attach Database. 

2. Enter the database properties in the pop-up window. 

Detach a database 

1. In the Navigation pane, right-click an attached database and choose Detach Database. 

Encrypt main database 

1. In the Navigation pane, right-click the main database and choose Encrypt Database. 

2. Enter the password in the pop-up window. 
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Decrypt main database 

1. In the Navigation pane, right-click the main database and choose Decrypt Database. 

2. Confirm decrypting in the dialog window. 

View the sqlite_master table 

1. In the Navigation pane, right-click a database and choose View Master Table. 

2. The sqlite_master table opens in Table Viewer. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. 

Note: The tabs and options in the designer depend on the server version. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 
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 View Builder Build the view visually. It allows you to create and edit views without 

knowledge of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Result -> 

Show Below Editor or Show in New Page. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

Other Objects 

Navicat also allows you to manage other SQLite objects: Index and Trigger. In the main window, click the 

corresponding button from the main toolbar to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining SQLite objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Database 

Option Description 

Analyze Database Collect statistics about the database. 

Vacuum Database Rebuild the database file. It only works on the main database. 

Reindex Database Delete and recreate all indexes within the database. 

Table 

Option Description 

Analyze Tables Collect statistics about the contents of the table. 

Reindex Tables Delete and recreate all indexes of the table. 

Get Rows Count Count the number of rows in the table. 

Index 

Option Description 

Reindex Delete and recreate the index. 
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Chapter 6 - Data Viewer 

About Data Viewer 

Data Viewer displays the data as a grid or a form. It allows you to view, update, insert, or delete data. To switch the 

view, click  or  at the bottom. 

Note: Form View is available only in Non-Essentials Edition. 

The toolbar of Data Viewer provides the following functions for managing data: 

 Begin Transaction / Commit / Rollback 

Click  Begin Transaction to start a transaction. To make permanent all changes performed in the 

transaction, click  Commit. Or, click  Rollback to undo work done in the current transaction. 

If Auto Begin Transaction is enabled under Options, transaction will be started automatically when opening 

the data viewer. 

 Edit TEXT / BLOB / BFile 

Allow you to view and edit the content of TEXT, BLOB and BFile fields. 

Note: Only Oracle supports BFile. 

 Filter Data 

Allow you to filter records by creating and applying filter criteria for the data grid. 

 Sort Records 

Sort records by custom order. 

 Import Data 

Import data from files. 

 Export Data 

Export data to files. 

Grid View & Form View 

Use Navigation Bar 

Data Viewer provides a convenient way to navigate among the records/pages using the Navigation Bar buttons. 
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Button Description 

 

Add Record - enter a new record. At any point when you are working in the data 

viewer, click on this button to get a blank display for a record. 

 

Delete Records - delete an existing record. 

 

Apply Changes - apply the changes. 

 

Discard Changes - remove all edits made to the current record. 

 

Refresh - refresh the data. 

 

Stop - stop when loading enormous data from server. 

 

First Page - move to first page. 

First Record - move to the first record. 

 

Previous Page - move to previous page. 

Previous Record - move one record back (if there is one) from the current record. 

 

Next Page - move to next page. 

Next Record - move one record ahead. 

 

Last Page - move to last page. 

Last Record - move to the last record. 

 

Limit Record Setting - set number of records showing on each page.  

 

Grid View - switch to grid view. 

 

Form View - switch to form view. 

Use the Limit Record Setting  button to enter to the edit mode. 

Limit Records  records per page 

Check this option if you want to limit the number of records showed on each page. Otherwise, all records will be 

displayed in one single page. And, set the value in the edit box. The number representing the number of records 

showed per page. 

Note: This setting mode will take effect on current object only. To adjust the global settings, see Options. 

 

Record a of b in page c 

The Record/Page Indicator displays the numbers representing the selected record and page. 

a - the selected record. 

b - number of records in the current page. 

c - the current page. 
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Edit Records 

The navigation bar allows you to switch the records quickly, insert, update or delete records. View data as a grid is 

most helpful for entering new records and editing old records in a table. 

To add a record 

1. Make sure that your cursor is situated in the first blank cell on the table, then enter the desired data. If you are 

adding the new record into an existing table, just simply click on an existing record and click  from the 

navigation bar or press CTRL+N to get a blank display for a record. 

2. Watch the graphics symbol in the record selectors box just to the left of your record. It will change from , 

which indicates that it is the current record, to , which indicates that you are editing this record. 

3. Just simply move to another record to save the record or click  from the navigation bar. 

To edit a record 

1. Select the record that you wish to edit by clicking in the specific field you want to change. 

2. Type in the new data for that field. 

3. Just simply move to another record, the new data will overwrite the previous data or click  from the 

navigation bar.  

Note: Close the table is another way to save the records. 

To edit multiple cells with same data 

1. Select a block of cells in the data grid. 

2. Type in the new data. 

Note: Changes will apply to multiple fields with compatible data type. 

To delete a record 

1. Select the record that you wish to delete. 

2. Just simply right-click and choose Delete Record or click  from the navigation bar. 

Edit Records with Special Handling 

To set the cell value to an empty string or NULL, right-click the selected cell and select Set to Empty String or Set to 

NULL. 

To view images in the grid, just simply choose View -> Display -> Show Image In Grid. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 
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Hint: To view/edit images in an ease way, see Image Editor. 

To edit a Date/Time record, just simply click  or press CTRL+ENTER to open the editor for editing. Choose/enter 

the desired data. The editor used in cell is determined by the field type assigned to the column. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

Date Time DateTime/Timestamp 

 

 

 

To edit an Enum record, just simply choose the record from the drop-down list. 

Note: Available only for MySQL, PostgreSQL and MariaDB. 

 

To edit a Set record, just simply click  or press CTRL+ENTER to open the editor for editing. Select the records from 

the list. To remove the records, uncheck them in the same way. 

Note: Available only for MySQL and MariaDB. 

 

To view BFile content, just simply choose View -> Display -> Preview BFile. 

Note: Available only for Oracle. 
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To generate UUID, right-click the selected cell and choose Generate UUID. 

Note: Available only for PostgreSQL. 

Edit Records with Foreign Key (Foreign Key Data Selection - Available only in Non-Essentials Edition) 

Foreign Key Data Selection is a useful tool for letting you to get the available value from the reference table in an 

easy way. It allows you to show additional records from the reference table and search for particular records. 

To include data to the record, just simply click  or press CTRL+ENTER to open the editor for editing. 

 

Just simply double-click to select the desired data. 

Hint: By default, the number of records showed is 1000. To show all records, click . To refresh the records, click 

 or press F5. 

Click  to open a pane on the left for showing a list of column names. Just simply click to show the additional column. 

To remove the columns, uncheck them in the same way. 

 

Hint: To set column in ascending or descending mode, right-click anywhere on the column and select Sort -> Sort 

Ascending / Sort Descending. 

Enter a search string into the Filter edit box and press ENTER to filter for the particular records. 
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Hint: To remove the filter results, simply remove the search string and press ENTER. 

Copy Data from Navicat 

Data that being copied from Navicat goes into the clipboard with the fields delimited by tabs and the records delimited 

by carriage returns. It allows you to easily paste the clipboard contents into any application you want. Spreadsheet 

applications in general will notice the tab character between the fields and will neatly separate the clipboard data into 

rows and columns. 

To select data using keyboard shortcuts 

CTRL+A Toggle the selection of all rows and columns in the data grid. 

SHIFT+ARROW Toggle the selection of cells as you move up/down/left/right in the data grid. 

To select data using mouse actions 

 Select the desired records by holding down the CTRL key while clicking on each row. 

 Select a block of cells. 

Note: After you have selected the desired records, just simply press CTRL+C or right-click it and choose Copy. 

Paste Data into Navicat 

Data are copied into the clipboard will be arranged as below format: 

 Data are arranged into rows and column. 

 Rows and columns are delimited by carriage returns/tab respectively. 

 Columns in the clipboard have the same sequence as the columns in the data grid you have selected. 

When pasting data into Navicat, you can replace the contents of current records and append the clipboard data into the 

table. To replace the contents of current records in a table, you must select the cells in the data grid whose contents 

must be replaced by the data in the clipboard. Just simply press CTRL+V or right-click and choose the Paste from the 

pop-up menu. Navicat will paste all the content in the clipboard into the selected cells. The paste action cannot be 

undone if you do not enable transaction. 
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Copy Records as Insert/Update Statements 

To copy records as Insert/Update statement, right-click the selected records and choose Copy As -> Insert Statement 

or Update Statement. Then, you can paste the statements in any editors. 

Copy Field Name 

To copy field names as tab separated values, right-click the selected columns/data and choose Copy As -> Tab 

Separated Values (Field Name only) from the menu. If you want to copy data only or both field names and data, you 

can choose Tab Separated Values (Data only) or Tab Separated Values (Field Name and Data) respectively. 

Save Data as a File 

You can save the data in the table grid to a file. Simply right-click a cell and choose Save Data As. Enter the file name 

and file extension in the Save As dialog. 

Note: Not available when multiple selection. 

Sort / Find / Replace Records 

Sort Records 

Server stores records in the order they were added to the table. Sorting in Navicat is used to temporarily rearrange 

records, so that you can view or update them in a different sequence. 

Move over the column caption whose contents you want to sort by, click the right side of the column and select Sort 

Ascending, Sort Descending or Remove Sort. 

 

To sort by custom order of multi fields, click  Sort from the toolbar. 
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Find Records 

The Find bar is provided for quick searching for the text in the editor window. Just simply choose Edit -> Find or press 

CTRL+F. Then, choose Find Data and enter a search string. 

The search starts at the cursor's current position to the end of the file. There will not have differentiates when 

performing a uppercase or lowercase search. 

To find for the next text, just simply click Next or press F3. 

 

Replace Records 

To open the Replace bar, simply check the Replace box and enter the text you want to search and replace. 

Click Replace or Replace All to replace the first occurrence or all occurrences automatically. 
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If you clicked Replace All, you can click Apply to apply the changes or Cancel to cancel the changes. 

 

Find Columns 

To search a column, just simply choose Edit -> Find or press CTRL+F. Then, choose Find Column and enter a search 

string. 

 

Filter Records 

Use either of the following methods to filter the data in the grid: 

 Right-click a field and select Filter -> Field xxx Value from the pop-up menu to filter records by the current 

value of the selected column. 

 The Custom Filter dialog is provided for quick building a simple filter. Just simply right-click a field and select 

Filter -> Custom Filter from the pop-up menu. Use character '_' to represent any single symbol in the 

condition and use character '%' to represent any series of symbols in the condition. 

 You can also customize your filter in a more complicated way by right-clicking a field and selecting Filter ->  

Filter from the pop-up menu or clicking  Filter from the toolbar. The Filter Wizard becomes visible at the 

top of the grid, where you can see the active filtering condition and easily enable or disable it by clicking a 

check box at the left. 

Manipulate Raw Data 

Navicat normally recognize what user has input in grid as normal string, any special characters or functions would be 

processed as plain text (that is, its functionality would be skipped). 
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Editing data in Raw Mode provides an ease and direct method to apply server built-in functions. To access Raw Mode, 

just simply select View -> Display -> Raw Mode. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

 

Format Data View 

Use the following methods to format the table grid: 

Move Columns 

1. Click on the column header and hold down the left mouse button. 

2. Move the pointer until a double black line appears in the desired location. 

3. Release the mouse and the column will move. 

 

Freeze Selected Column 

If there are many columns in the table and you want to freeze one or more columns to identify the record, just simply 

right-click the column you want to freeze and select Display -> Freeze Selected Column or select from the View 

menu. 

The frozen columns will move to the leftmost position in the table grid. This action will locks the frozen columns, 

preventing them from being edited. 

To unfreeze the columns, just simply right-click anywhere on the table grid and select Display -> Unfreeze Columns 

or select from the View menu. 

Set Column Width 

 Click right border at top of column and drag either left or right. 

 Double-click right border at top of column to obtain the best fit for the column. 

 Right-click the column you want to set the column width with and select Display -> Set Column Width or 

select from the View menu. Specify width in the Set Column Width dialog. 

Hint: The result only applies on the selected column. 

Set Row Height 
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Right-click anywhere on the table grid and select Display -> Set Row Height or select from the View menu. Specify 

row height in the Set Row Height dialog. 

Hint: This action applies on the current table grid only. 

Show/Hide Columns 

If there are many columns in the table and you want to hide some of them from the table grid, just simply right-click 

anywhere on the table grid and select Display -> Show/Hide Columns or select from the View menu. Select the 

columns that you would like to hide. 

The hidden columns will disappear from the table grid. 

To unhide the columns, just simply right-click anywhere on the table grid and select Display -> Show/Hide Columns 

or select from the View menu. Select the columns that you would like to redisplay. 

 

Show/Hide ROWID 

If you want to display or hide the rowid (address) of every row, right-click anywhere on the table grid and select Display 

-> Show/Hide ROWID or select from the View menu. 

The ROWID column will be showed in the last column. 

Note: Available only for Oracle and SQLite. 

Assistant Editors 

Navicat provides powerful assistant editors to view and edit TEXT, BLOB, BFile and Dynamic Column fields content. 

The editor allows you to view, update, insert, or delete data in a table. Click  Text,  Hex,  Image,  Web 

and  Dynamic Column from the toolbar to activate the appropriate viewer/editor. 

Note: Oracle BFile fields cannot be edited. 

The Text pane allows you to edit data as a simple text. To change the syntax highlight, simply right-click the empty 

space and choose Language. Use the  button on the navigation bar to update the changed records to the table. 

The Hex pane allows you to edit data in hexadecimal mode. Use the  button on the navigation bar to update the 

changed records to the table. 

Note: Use the INSERT key on the keyboard to switch between Insert and Overwrite modes. 
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The Image pane allows you to show data as image. Use the  Load,  Save to disk and  Clear buttons to 

load/remove the image from a file, and save the image to a file. 

The Web pane allows you to show data with HTML codes as in a web browser. 

The Dynamic Column pane allows you to edit dynamic column data in MariaDB. Use the  and  buttons on the 

left to add and delete values. 

Filter Wizard 

Filter Wizard allows you to facilitate creating and applying filter criteria that you specify for the table grid. Moreover, it 

allows you to save filter criteria as a profile for future use. Click  Filter from the toolbar to activate the filter. 

 

1. To add a new condition to the criteria, just simply click <Add>. 

2. Click on the column box (next to the checkbox) and choose a table column. 

3. Click on the operator box (next to the column box) and choose a filter operator. You can choose Custom from 

the list to enter the condition manually. 

Filter Operator Result 

is equal to <?> My_Field = 'your_value' 

is not equal to <?> My_Field <> 'your_value' 

is less than <?> My_Field < 'your_value' 

is less than or equal to <?> My_Field <= 'your_value'  

is greater than <?> My_Field > 'your_value'  

is greater than or equal to <?> My_Field >= 'your_value' 

contains <?> My_Field LIKE '%your_value%' 

contains (case insensitive) <?> My_Field ILIKE '%your_value%' 
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Available only for PostgreSQL. 

does not contain <?> My_Field NOT LIKE '%your_value%' 

does not contain (case 

insensitive) <?> 

My_Field NOT ILIKE '%your_value%' 

Available only for PostgreSQL. 

begin with <?> My_Field LIKE 'your_value%' 

end with <?> My_Field LIKE '%your_value' 

is null My_Field IS NULL 

is not null My_Field IS NOT NULL 

is empty My_Field = '' 

is not empty My_Field <> '' 

is between <?> <?> ((My_Field >= your_value1) AND (My_Field <= your_value2)) 

is not between <?> <?> NOT ((My_Field >= your_value1) AND (My_Field <= 

your_value2)) 

is in list <?> My_Field IN ('aaa','bbb',...) 

is not in list <?> My_Field NOT IN ('aaa','bbb',...) 

4. Click on the criteria values box (next to the operator box) to activate the appropriate editor and enter the criteria 

values. The editor used in criteria values box is determined by the data type assigned to the corresponding 

column. 

5. Click on the logical operator box (next to the criteria values box) and choose and, or, and not, or not. 

6. Repeat step 1-5 to add another new condition. 

7. Click <Apply (Ctrl+R)> or press CTRL+R to see the result of the filtering you made. 

Hint: To set compound filter, simply right-click on a selected condition and choose Indent or Outdent. 

You are allowed to save filter criteria to and load them from profiles for future use. Just simply right-click on the Filter 

Wizard and select Open Profile, Save Profile, Save As or Delete Profile. 
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Chapter 7 - Query 

About Query 

A query is used to extract data from the database in a readable format according to the user's request. Navicat provides 

two powerful tools for working with the SQL queries: Query Editor for editing the query text directly and Query Builder 

for building queries visually. You can save your queries for setting automation tasks. In the main window, click  

Query to open the query object list. You also can click  New Query in the main toolbar to create a new query 

without opening any connections. 

Hint: Queries (.sql) are stored under the Settings Location. To open the folder, right-click a query and choose Open 

Containing Folder. If the connection is synchronized to Navicat Cloud, its queries are stored in the Cloud. 

Query Designer 

Button Description 

 Query Builder Open the SQL Builder for building queries visually. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

 Code Snippet Show the Code Snippet panel. 

 Text Activate the assistant editors for viewing and editing data. 

 Export Result Export the result of the query. 

 Run Execute the query: Run, Run Current Statement, or Run Selected 

(when highlighted SQL). 

 Stop Stop the executing query. 

 Explain Show the Query Plan of the query. 

Open an external SQL file in Navicat 

1. In the main window, click  New Query. 

2. In Query Designer, choose File -> Open External File. 

3. Select the file and choose the encoding. 

4. Click Open. 

Save an opened external SQL file as a Navicat query 

1. In Query Designer, choose File -> Save As Navicat Query. 

2. Enter the query name and choose the save location. 

3. Click OK. 

Save a Navicat query as an external SQL file 

1. In Query Designer, choose File -> Save As External File. 
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2. Choose the save path and enter the file name. 

3. Click Save. 

SQL Editor 

SQL Editor allows you to create queries and views. It allows you to create and edit SQL text, prepare and execute 

selected queries. You can define multiple SQL statements in one query window. Drag-and-drop or double-click an 

identifier in the right Identifiers pane to add it to the editor. 

Hint: SELECT statement will be automatically generated in SQL Editor while you build in SQL Builder. 

Navicat provides a wide range advanced features, such as compelling code editing capabilities, smart code-completion, 

SQL formatting, and more. 

SQL Formatting 

To change the SQL statement format, simply choose from the Format menu -  

Indent 

Increase/decrease indent for the selected lines of codes. 

Comment 

Comment/uncomment the selected lines of codes. 

Convert case 

Format the selected codes into upper/lower case. 

Beautify SQL (Available only in Non-Essentials Edition) 

Format the selected codes with the Beautify SQL settings. 

Beautify SQL With (Available only in Non-Essentials Edition) 

Change the SQL beautifier options. 

Option / Button Description 

Short brace length Set the length of the short brace. 

Upper case keywords Format all the SQL keywords to upper case. 

Beautify Save and apply the SQL beautifier options. 

Minify SQL (Available only in Non-Essentials Edition) 

Minify the format of the SQL in the SQL Editor. 

Code Completion (Available only in Non-Essentials Edition) 
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Code completion feature in Navicat pops up a list of suggestions as you type your SQL statement in the editor. It 

assists you with statement completion and the available properties of database objects, for example databases, tables, 

fields, views etc with their appropriate icons and information. You can update the code suggestions with latest 

database information by choosing Edit -> Code Completion -> Update Code Completion Info. 

To invoke code completion, just simply press '.' for the available properties of database object currently in the scope. 

When the suggestion list appears, press TAB to insert the first item. You also can select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 

 

In addition, code completion can be invoked by typing a character or pressing ESC / CTRL+SPACE on your keyboard 

for SQL keywords/database objects. 

If you select a snippet name from the list, the saved code will be inserted to the editor. 

 

Hint: Resize the suggestion list by dragging the lower right corner. 

You can enable or disable the code completion feature in Options. 

Code Folding 

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in SQL 

Editor. 

A block of code that can be folded is indicated by an icon  to the left of the first line of the block. A vertical line 

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon  

to left of the code block. You can fold the block by clicking  or expand it by clicking . 
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Brace Highlight 

Navicat supports to highlight the matching brace in the editor, i.e. () . 

Note: The cursor must be on a brace to show the highlight. 

 

Find and Replace 

Find 

The Find bar is provided for quick searching for the text in the editor. Just simply choose Edit -> Find from the menu or 

press CTRL+F, and then enter a search string. 

 

The search starts at the cursor's current position to the end of the file. 

To find the next occurrence, just simply click Next or press F3. 

Replace 
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To open the Replace bar, simply check the Replace box. Then, enter the text you want to search and replace. 

Click the Replace button to replace the first occurrence. 

Click the Replace All button to replace all occurrences automatically. 

 

There are some additional options for Find and Replace, click : 

Option Description 

Highlight All Highlight all matches in the editor. 

Incremental Search Find matched text for the search string as each character is typed. 

Match Case Enable case sensitive search. 

Regular Expression Search regular expressions. 

Whole Word Return the objects that match the entire word of the search string. 

Copy with Quotes 

To copy the SQL statement with quotes, just simply right-click the highlighted SQL. Then, select Copy with quotes 

and choose the format. 

Word Wrap 

In the Word Wrap mode, the horizontal scrollbar is removed. SQL statement that exceed the width of the editor window 

size wraps to the next line. To enable Word Wrap, choose View ->  Word Wrap. 

Zoom In/Zoom Out 

Navicat has the ability to zoom in or zoom out the SQL in the editor. The zooming options are available in View -> 

Display -> Zoom. The same effect can be achieved with keyboard shortcuts. 

Zoom In: [CTRL+=] 

Zoom Out: [CTRL+-] 

Reset: [CTRL+0] 

Note: Editors that are opened in different tabs or windows will not be effected by the zoom. 

SQL Builder (Available only in Non-Essentials Edition) 

Navicat provides SQL Builder for building queries visually. It allows you to create and edit queries without knowledge of 

SQL. The database objects are displayed in left pane. Whereas in the right pane, it is divided into two portions: the 

upper Diagram Design pane, and the lower Syntax pane. 
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In Query Designer, click the  Query Builder button to open the visual SQL Builder. 

Note: SQL Builder supports SELECT statement only. Use SQL Editor for creating complex queries. 

Drag a table/view from the left pane to the Diagram Design pane or double-click it to add it to query. To include a field in 

the query, check the left of the field name in the Diagram Design pane. To include all the fields, click at the left of the 

object caption. 

To remove the object from the Diagram Design pane, click the cross button at the object caption. 

To add the table/view alias, simply double-click the table/view name and enter the alias in the Diagram Design pane. 

Hint: You are also allowed to set criteria by right-click any fields from the Diagram Design pane. 

 

Set Field Association 

To associate database objects by two fields, just drag one field from the object to another and a line will appear 

between the linked fields. 

Hint: To delete all the links of some object, click button '-' next to the object alias. 

Go to the Syntax pane to change the association between the links, click the operator and choose the properties item 

from the pop-up menu. You can change the association condition by choosing it from the list (=, <>, <, <=, >, >=). Click 

OK to confirm the changes you made. Also you can change the type of Join. 

Set Output Fields 

The fields you have selected in the Diagram Design pane will be displayed in the Syntax pane which allows you to set 

their displaying order and modify the output fields of the query using <Distinct>, <func> and <Alias>. 
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<Distinct> 

Enable this option if you wish the repeated records are not included into the query result. 

<Func> 

Set the aggregate functions (SUM, MAX, MIX, AVG, COUNT) for each field. 

<Alias> 

Change the output query field name. 

Set Criteria 

To add a condition, click the <--> = <--> from the WHERE clause in the Syntax pane. Click <--> to choose the field from 

the list of all the table fields, available in the query. To define your own criteria, type your values directly in the Edit Tab. 

Clicking = to set condition operator. 

Set Grouping Criteria 

You can set the conditions for grouping query records from the GROUP BY clause in the Syntax pane. They are set in 

the same way as setting criteria. The conditions will be included into the HAVING statement of the current query. 

Set Sorting Criteria 

You can set the way of sorting query records from the ORDER BY clause in the Syntax pane. To change the sorting 

direction, click on either ASC or DESC. 

Set Limit Criteria 

LIMIT clause is used to limit your query results to those that fall within a specified range. You can use it to show the first 

X number of results, or to show a range X - Y results.  

It is phrased as Limit X, Y and included at the end of your query. X is the starting point (remember the first record is 0) 

and Y is the duration (how many records to display). 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Code Snippets (Available only in Non-Essentials Edition) 

Code Snippets provide a easy way for you to insert reusable code into SQL statements when working in the SQL Editor. 

The Code Snippet pane is on the right side of the SQL Editor. If the editor window is opened in the Navicat main 

window, you can click the  icon in the Information pane to open the library. 

The library includes built-in and user-defined snippets. Choose a label from the drop-down list or enter a search string 

in the Search box to filter the list. If you want to show the available snippets according to your database type, you can 

right-click anywhere on the library and disable Show Snippets For Other Database Type. 
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Built-in snippets are non-editable. A user-defined snippet can be edited by double-clicking it in the library. If you want to 

hide the built-in snippets, you can right-click anywhere on the library and disable Show Preset Snippets. 

Use Code Snippets 

There are two ways to insert a snippet into the editor. 

 You can start typing the name of a snippet in the editor. Smart code completion will pop up a list of suggestions 

for the word completion automatically. Select a snippet name from the list, the saved code will be inserted to 

the editor. 

 

 You can simply drag and drop a snippet from the library into the editor. 

After inserting the snippet with placeholders to the editor, you can easily navigate to them by clicking on one of the 

placeholders, and then using the TAB key and entering the information. 
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Create Code Snippets 

You can create your own code snippets and add them to the library. To create a code snippet, select your desired code 

in the editor, then right-click and select Create Snippet. 

Alternatively, click  in the Code Snippet pane. If you use this method, you must manually enter the code in the New 

Snippet window; code selected in the editor is not automatically added to the Code box. 

Hint: Code snippets (.nsnippet) are stored in the snippets folder under the Profiles Location. 

Option / Button Description 

Untitled text box Enter the name of the snippet that displays in the library and the code completion 

list. 

Database Type Choose the database server type of the snippet. 

Label Choose an existing label or enter a new label name for the snippet. 

Remarks Enter a description for the snippet that displays in the library. 

Code Enter the code. 

 

Add a placeholder by highlighting any words in the code and click this button. The 

placeholder will be highlighted in light green. 

 

Remove a placeholder by highlighting it in the code and click this button. 

 

Query Results 

You can run the query in any servers. Select the target connection, database and/or schema from the drop-down list on 

the toolbar, and then click  Run. If the query statement is correct, the query executes and, if the query statement is 

supposed to return data, the Result tab opens with the data returned by the query. If an error occurs while executing 

the query, execution stops, the appropriate error message is displayed. 

The Result tab displays the result data, returned by the query, as a grid. Data can be displayed in two modes: Grid 

View and Form View. See Data Viewer for details. 

Note: Navicat supports to return 10 result sets. 

You can choose to show query results below the editor or in a new tab by selecting View -> Result -> Show Below 

Editor or Show in New Page. 

You are allowed to run selected portion of query, just simply highlight SQL in SQL Editor and click  Run Selected. 

To run the current statement your cursor is on (position the cursor within the desired statement), just simply click the 

down arrow next to the  Run button and select Run Current Statement. 

Custom Tab Name 

To customize the names of the result tabs, simply add -- NAME:tab_name or /*NAME:tab_name*/ before each 

SELECT statement in the SQL Editor. 
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Show Profile and Status (Available only for MySQL and MariaDB) 

To show the profile and status when running the query, simply choose View -> Show Profile and Status and click  

Run on the toolbar. 

The Profile tab displays the query profile: Table lock, System lock, Statistic, etc. 

Note: For MySQL 5.0, supported from 5.0.37 or above. For MySQL 5.1, supported from 5.1.24 or above. 

The Status tab displays the query status: Bytes received, Bytes sent, etc. 

Query Parameters 

Query supports using of parameters inside the query text. You can set query parameters to add variable values to a 

query each time you run it. The parameter should appear as an identifier with $ at its beginning, quote with [ ], e.g. 

[$any_name]. 

Execute the query and the Input Parameter dialog is provided for you to enter the desired data you wish to search. 

Check the Raw Mode option to pass the inputted values to the query without quotation marks. 

Debug Oracle Query (Available only in Non-Essentials Edition) 

To debug an Oracle query, click  Debug on the toolbar to launch the Oracle Debugger. 

Enter the parameters if the query has input parameters. 
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Chapter 8 - Model (Available only in Navicat 

Premium and Enterprise Edition) 

About Model 

Model is a powerful tool for creating and manipulating physical database models. In the main window, click  Model 

to open the model object list. 

Some of key features are listed here: 

 Create and manipulate a physical model graphically. 

 Reverse engineer a database/schema, tables or views to a physical model. 

 Forward engineer a physical model to a sql file or database/schema. 

 Create and edit table structures directly. 

To create a model, click  New Model from the object toolbar. The New Model window will pop up for you to select 

the Database and Version. 

Hint: Model files (.ndm) are saved under the Profiles Location. To open the folder, right-click a model file and choose 

Open Containing Folder. If the model is synchronized to Navicat Cloud, it is stored in the Cloud. 

Model Window 

The Model Window consists of a toolbar, several panes and a diagram canvas for you to design your model. A model 

file can have more than one diagram. Each diagram is represented by a tab in the model. To create a new diagram, 

choose Diagram -> New Diagram from the menu bar. 
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 Toolbar 

The Toolbar is located near the top of the Model Window. You can use the toolbar to perform some basic tasks, such 

as adding tables or views, applying Auto Layout feature, etc. 

 Explorer Pane 

The Explorer pane has two tabs: Model and Diagram. The Model tab holds all tables or views in the model, including 

those used in each individual diagram. You can simply drag an object from the Model tab and drop to the active 

diagram canvas. The Diagram tab holds all the objects (tables, views, foreign keys, layers, notes, images, etc) added to 

the active diagram. If the Explorer pane is hidden, choose View -> Show Explorer from the menu bar. 

 History Pane 

The History pane shows all the actions that you have taken. Simply click an action to restore that state. If the History 

pane is hidden, choose View -> Show Explorer and Show History from the menu bar. 

 Properties Pane 

The Properties pane includes the Model, Diagram and Object tabs for setting default properties for your model. You 

can edit the properties settings of the model, the active diagram and the selected objects quickly. If the Properties pane 

is hidden, choose View -> Show Properties from the menu bar. 

Option Description 

Begin Arrow Style The style of the arrow's back. 

Black and White Check this box to change the diagram color to black and white. 

Bold Check this box or press CTRL+B to bold the table, view, foreign key or shape. 

Border Color The color of the shape's border. 

Cap Style The cap style of the line/arrow. 
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Case Sensitivity The case sensitivity of the table or view names. Available only for MySQL and 

MariaDB models. 

Color The color of the object. 

Dash Style The dash style of the line/arrow. 

Database Type The database type of the model. 

Database Version The database version of the model. 

Diagram Notation The notation of the diagram. The value for this can be Default, Simple, 

IDEF1X, UML, IE (Crow's Foot) or Classic. 

End Arrow Style The style of the arrow's front. 

Font Bold Check this box to bold the note/label font. 

Font Color The font color of the note, label or layer. 

Font Italic Check this box to apply an italic style to the note or label font. 

Font Name The font name of the note, label or layer. 

Font Size The font size of the note, label or layer. 

Height The height of the object. 

Height (pages) The height of the diagram (number of papers). 

Join Style The join style of the line/arrow. 

Left The number of pixels from the object to the left side of the canvas. 

Model Type The type of the model. 

Name The name of the object. 

Opacity The transparency of the image/shape. The value for this can be between 0 

and 100. Use 100 for opacity and 0 for transparent. 

Referenced Cardinality The foreign key cardinality of the referenced (parent) table. 

Referencing Cardinality The foreign key cardinality of the referencing (child) table. 

Schema Name The schema names of the table/view. 

Show Name Check this box to show the name of the foreign key or shape. 

Show Schema Name Check this box to show the schema names of the tables/views in the diagram. 

Show View Relationships Check this box to show the relationship line of the view. 

Table Font Name The font name of the tables. 

Table Font Size The font size of the tables. 

Top The number of pixels from the object to the top of the canvas. 

Visible Check this box to show the foreign key/relationship lines. 

Width The width of the object. 

Width (pages) The width of the diagram (number of papers). 

 Overview Pane 

The Overview pane displays the whole active diagram in the canvas. To zoom in or zoom out the selected area of the 

diagram, adjust the slider. If the Overview pane is hidden, choose View -> Show Properties and Show Overview from 

the menu bar. Same effect can be achieved with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel Up] 
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Zoom out: [CTRL+-] or [CTRL+Mousewheel Down] 

 Diagram Canvas 

You can design your diagram on the Diagram Canvas. 

Build Diagram 

Add Tables 

To add a new table, click the  button from the toolbar and click anywhere on the canvas. To add an existing table 

from the Explorer's Model tab, simply drag and drop the selected table from the Model tab to the canvas. 

For Default diagram notation, the  icon means the field is a primary key. The  icon indicates that the field serves 

as an index. 

Note: If you right-click a field, you can choose to add, insert, delete, rename the field and set the field as primary key. 

The pop-up menu options of the table object in canvas include: 

Option Description 

Design Table Edit the table structure in a table designer, e.g. fields, indexes, foreign 

keys, etc. The tabs and options in the designer depend on the 

diagram database type you are chosen. 

Add Related Objects Add all related tables/views to the selected table. 

Add Field Add fields to the existing table. 

Cut Remove the table from the diagram and put it on the clipboard. 

Copy Copy the table from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Tables Select all tables in the diagram. 

Delete Delete a table from the diagram or from both diagram and model. 

Rename Change the name of the table. 

Color Change the color of the table. 

Size to Fit Resize the table automatically to fit its contents. 

Bring to Front Bring the table to the foreground. 

Send to Back Move the table to the background. 

 

Add Views 

To add a new view, click the  button from the toolbar and click anywhere on the canvas. To add an existing view 

from the Explorer's Model tab, simply drag and drop the selected view from the Model tab to the canvas. 

Note: If you right-click the view connector, you can choose to add or delete vertices and change its color, or go to the 

source view or the target table. 

The pop-up menu options of the view object in canvas include: 
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Option Description 

Design View Edit the view structure in a view designer. The tabs and options in the 

designer depend on the diagram database type you are chosen. 

Add Related Objects Add all related tables/views to the selected view. 

Cut Remove the view from the diagram and put it on the clipboard. 

Copy Copy the view from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Views Select all views in the diagram. 

Delete Delete a view from the diagram or from both diagram and model. 

Rename Change the name of the view. 

Color Change the color of the view. 

Size to Fit Resize the view automatically to fit its contents. 

Bring to Front Bring the view to the foreground. 

Send to Back Move the view to the background. 

 

Add Foreign Keys 

To add a foreign key, click the  button from the toolbar and drag and drop a field from the child table to the parent 

table. To show/hide the linked name label, simply check/uncheck the Show Name option in the Properties pane. 

When you move your mouse over a foreign key connecter, the border of the parent and the child tables turn to green 

and blue respectively. Also, the referenced fields and the referencing fields are highlighted. 

The pop-up menu options of the foreign key in canvas include: 

Option Description 

Design Relation Edit the foreign key in a table designer. The options in the designer 

depend on the diagram database type you are chosen. 

Cardinality on table_name1 Set the cardinality on table_name1: None, One and Only One, Many, 

One or Many, Zero or One, Zero or Many. 

Cardinality on table_name2 Set the cardinality on table_name2: None, One and Only One, Many, 

One or Many, Zero or One, Zero or Many. 

Add Vertex Add a vertex on a foreign key connecter. 

Delete Vertex Delete a vertex on a foreign key connecter. 

Delete All Vertices Delete all vertices on a foreign key connecter. 

Go to Source Go to and select the source (child) table. 

Go to Target Go to and select the target (parent) table. 

Paste Paste the content from the clipboard into the diagram. 

Select All Relations Select all foreign keys in the diagram. 

Delete from Diagram and 

Model 

Delete a foreign key from both diagram and model. 

Color Change the color of the foreign key. 
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Add Labels 

Labels are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. To add a new label, click the  button from the toolbar and click anywhere on the canvas. 

The pop-up menu options of the label object in canvas include: 

Option Description 

Edit Change the content of the label. 

Cut Remove the label from the diagram and put it on the clipboard. 

Copy Copy the label from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Labels Select all labels in the diagram. 

Delete Delete a label from the diagram. 

Size to Fit Resize the label automatically to fit its contents. 

Bring to Front Bring the label to the foreground. 

Send to Back Move the label to the background. 

 

Add Notes 

Notes are typically used to help document the diagram design process. For example, to explain a grouping table 

objects. To add a new note, click the  button from the toolbar and click anywhere on the canvas. 

The pop-up menu options of the note object in canvas include: 

Option Description 

Edit Change the content of the note. 

Cut Remove the note from the diagram and put it on the clipboard. 

Copy Copy the note from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Notes Select all notes in the diagram. 

Delete Delete a note from the diagram. 

Color Change the color of the note. 

Size to Fit Resize the note automatically to fit its contents. 

Bring to Front Bring the note to the foreground. 

Send to Back Move the note to the background. 

 

Add Images 

To add a new image, click the  button from the toolbar and click anywhere on the canvas. Then, select an image 

file in the Open dialog box. 

The pop-up menu options of the image object in canvas include: 
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Option Description 

Reset Size Reset the size of the image to its original size. 

Reset Aspect Ratio Maintain the image original width to height ratio. 

Cut Remove the image the diagram and put it on the clipboard. 

Copy Copy the image from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Images Select all images in the diagram. 

Delete Delete an image from the diagram. 

Bring to Front Bring the image to the foreground. 

Send to Back Move the image to the background. 

 

Add Shapes 

To add a new shape (line, arrow, rectangle, ellipse, user, database, cloud, trigger, server, desktop or mobile), click the 

 button from the toolbar and choose the type of shape. Then, click anywhere on the canvas. To show/hide the linked 

name label, simply check/uncheck the Show Name option in the Properties pane. 

The pop-up menu options of the shape object in canvas include: 

Option Description 

Reset Aspect Ratio Maintain the shape original width to height ratio. 

Only for rectangle, ellipse, user, database, cloud, trigger, server, 

desktop and mobile. 

Cut Remove the shape from the diagram and put it on the clipboard. 

Copy Copy the shape from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Shapes Select all the shapes in the diagram. 

Delete Delete a shape from the diagram. 

Color Change the color of the shape. 

Border Color Change the color of the shape's border. 

Only for rectangle, ellipse, user, database, cloud, trigger, server, 

desktop and mobile. 

Begin Arrow Style Change the style of the arrow's back. 

Only for arrow. 

End Arrow Style Change the style of the arrow's front. 

Only for arrow. 

Add Vertex Add a vertex on a line or arrow. 

Only for line and arrow. 

Delete Vertex Delete a vertex on a line or arrow. 

Only for line and arrow. 

Delete All Vertices Delete all vertices on a line or arrow. 

Only for line and arrow. 
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Bring to Front Bring the shape to the foreground. 

Send to Back Move the shape to the background. 

 

Add Layers 

Layers are used to help organize objects (e.g. tables, notes, images, etc) on the canvas. You can add all related 

objects to the same layer. For example, you may choose to add all your sales related tables to one layer. To add a new 

layer, click the  button from the toolbar and click anywhere on the canvas. 

The pop-up menu options of the layer object in canvas include: 

Option Description 

Cut Remove the layer from the diagram and put it on the clipboard. 

Copy Copy the layer from the diagram to the clipboard. 

Paste Paste the content from the clipboard into the diagram. 

Select All Layers Select all layers in the diagram. 

Delete Delete a layer from the diagram. 

Color Change the color of the layer. 

Size to Fit Resize the layer automatically to fit its contents. 

Bring to Front Bring the layer to the foreground. 

Send to Back Move the layer to the background. 

 

Work with Diagram Canvas 

Show Grid 

To turn the grid on in the diagram canvas, choose View -> Show Grid from the menu bar. 

Snap to Grid 

To align objects on the canvas with the grid, choose View -> Snap To Grid from the menu bar. 

Change Diagram Notation 

To change the notation of the diagram, choose Diagram -> Diagram Notation from the menu bar. 

Option Description 

Default The default notation style used in Navicat. 

Simple A simple notation style. The table or view will only show the 

name. 

IE (Crow's Foot) Crow's Foot notation style. 

IDEF1X The ICAM DEFinition language information modeling method. 

UML Universal Modeling Language style. 

Classic A classic notation style. 

Black and White Change the color of the diagram to black and white. 
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Show Schema Name Show the schema names of the tables and views in the diagram. 

Change Diagram Dimensions 

To change the number of pages used in the diagram, choose Diagram -> Diagram Dimensions from the menu bar 

and set the Width and the Height. 

Align Objects 

To align objects on the canvas, select more than one object (tables, views, notes, labels, images or shapes), then 

right-click and choose Alignment -> Align Left, Align Center, Align Right, Align Top, Align Middle or Align 

Bottom. 

Change Objects Distribution 

To distribute objects on the canvas, select more than one object (tables, views, notes, labels, images or shapes), then 

right-click and choose Distribute -> Horizontal or Vertical. 

Change Page Setup 

To change paper size, orientation and margins, choose File -> Page Setup. 

Apply Auto Layout 

To automatically arrange objects on the canvas, click the  button. To change the Auto Layout format settings, 

simply choose Diagram -> Auto Layout with from the menu bar and set the following options: 

Option Description 

Auto Diagram Dimension Choose the suitable diagram dimension automatically. 

Auto Size Tables To Fit Resize the table to fit its content automatically. 

Quality The quality of the auto layout output. 

Object Distance The distance between the objects in the diagram. 

 

Reverse Engineering 

Reverse Engineering is one of the key features of Model. This feature allows you to load already existing database 

structures to create new diagrams. It supports importing databases, schema, tables or views. 

Navicat provides a step-by-step wizard for you to complete the task: 

1. Select File -> Import from Database. 

2. Select a connection. 

3. Choose databases, schemas, tables or views you want to import. 

4. Click Start. 
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You can also simply create a new model using reverse engineering in the Navicat main window. Right-click an opened 

database/schema, tables or views and select Reverse Database to Model, Reverse Schema to Model, Reverse 

Tables to Model or Reverse Views to Model from the pop-up menu. 

Forward Engineering 

Synchronize to Database 

The Synchronize to Database feature allows you to compare a model with an existing database or schema, states the 

differences between their structures, and offers synchronizing the structures in model to the target connection. 

Navicat provides a step-by-step wizard for you to complete the task: 

1. Select File -> Synchronize to Database. 

2. Select the synchronization type. 

3. Select the source databases, schemas, tables or views and the target connection from existing connections. 

4. Choose the compare and execution options. 

5. Click Compare to generate a set of scripts that show the differences between source and target objects. 

6. Select the scripts you want to run. 

7. Click Run Query. 

Select Synchronization Type 

Sync with selected schemas 

Set the synchronization to work on all objects in the selected schemas. 

Sync with selected objects 

Set the synchronization to work on the selected objects only. 

Select Schemas/Objects and Connection 

In this step, choose one or more schemas or objects in model to compare to the target schemas or objects. If objects in 

model are from existing schemas, you can select the existing schemas. Otherwise, enter a target schema name in 

Objects without schema will synchronize to this schema for the source model objects to compare to. 

Then, choose target connection and database from existing connections. 

Select Compare and Advanced Options 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 
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Compare auto increment value 

Check this option if you want to compare the auto increment values of tables. 

Compare character set 

Check this option if you want to compare the character sets of tables. 

Compare checks 

Check this option if you want to compare checks. 

Compare collation 

Check this option if you want to compare the collations of tables. 

Compare definers 

Check this option if you want to compare the definers of views. 

Compare excludes 

Check this option if you want to compare excludes. 

Compare foreign keys 

Check this option if you want to compare table foreign keys. 

Compare identifier with case sensitive 

Check this option if you want to compare table identifier with case sensitive option. 

Compare indexes 

Check this option if you want to compare indexes. 

Compare primary keys 

Check this option if you want to compare table primary keys. 

Compare rules 

Check this option if you want to compare rules. 

Compare tables 

Check this option if you want to compare tables. 

Compare triggers 

Check this option if you want to compare triggers. 
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Compare uniques 

Check this option if you want to compare uniques. 

Compare views 

Check this option if you want to compare views. 

Continue on error 

Ignore errors that are encountered during the synchronization process. 

SQL for objects to be changed 

Check this option to include all related SQL statements if database objects will be changed in the target. 

SQL for objects to be created 

Check this option to include all related SQL statements if new database objects will be created in the target. 

SQL for objects to be dropped 

Check this option to include all related SQL statements if database objects will be dropped from the target. 

View Comparison Result 

The Source Objects and Target Objects views show the differences between model and database/schema objects 

after the comparison of their structures, providing with the detailed SQL statements shown in the Queries for 

Modification list. 

The red item represents the non-existence for the other database/schema. The blue item represents the existence for 

the other database/schema, but different definition detected. 

 

All the scripts are unchecked in the Queries for Modification list by default. Check the scripts you want to apply to the 

target. 
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You can highlight multiple lines of scripts, and then right-click to show the pop-up menu. Choose Checked Scripts 

Detail to view the full SQL statements you selected. 

 

Click the Run Query button to execute the selected query. 

Export SQL 

After finishing your model, you can save table structures and relations from the model into a script file. The Export SQL 

feature generates a SQL file for the script. To start the Export SQL feature, select File -> Export SQL from the menu 

bar. 

General Properties 

File 

Set the output file name and location. 

Objects 

Choose objects in the model you wish to export. 

Advanced Properties 

Note: The following options depend on the diagram database type you are chosen and sort in ascending order. 

Default Schema 

Set the schema name for the objects without schema settings. 

Include auto increment 

Include table auto increment in file with this option is on. 

Include character set 

Include table and field character set in file with this option is on. 

Include checks 

Include checks in file with this option is on. 
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Include collation 

Include table collation in file with this option is on. 

Include Drop SQL 

Include drop object SQL statements in file with this option in on. 

Include Drop With CASCADE 

Include drop object SQL statements with cascade option in file with this option in on. 

Include excludes 

Include excludes in file with this option is on. 

Include foreign keys 

Include foreign keys in file with this option is on. 

Include indexes 

Include indexes in file with this option is on. 

Include primary keys  

Include primary keys in file with this option is on. 

Include rules 

Include rules in file with this option is on. 

Include schema 

Include the schema name in file with this option is on. Otherwise, only object names are included in SQL statements. 

Include triggers 

Include triggers in file with this option is on. 

Include uniques 

Include uniques in file with this option is on. 

Server Version 

Select the server version for the SQL file. 
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Model Conversion 

Navicat allows you to convert your models from one database type to another database type, e.g. MariaDB 10.0 

physical model to PostgreSQL 9.0 physical model. 

During the conversion, all data types are converted automatically. The conversion process does not change the SQL 

syntax of views if converting from one database type to another. If the target database version is MySQL 4.0 or below, 

all views will be removed. 

To convert an opened model file, choose File -> Convert Model To. Then, select the target Database and Version. 

Preview and Print Model 

To preview the pages before printing, simply click the  button. The model can be printed to the printer or to various 

file formats. 

Print to a printer 

Choose File -> Print to send your diagram directly to the printer. You can set the printer option in the pop-up window. 

Print to a file 

Choose File -> Print As and choose the file format to create a PDF, PNG or SVG file of your diagram. 

Model Hints and Tips 

Navicat provides some useful hints to work on the model more effectively. 

Locate Object in the Diagram Canvas 

Double-click an object in the Explorer's Diagram tab will jump to the corresponding object in the Diagram Canvas. 

Delete Object from Model 

Select an object in the Diagram Canvas and press SHIFT+DELETE. 

Open Table/View Designer 

Double-click a table/view in the Explorer's Model Tab or the Diagram Canvas. 

Get Table/View Structure (SQL Statement) 

Select and copy a table/view in the Diagram Canvas, and paste it to other text editors. 

Design Field without Table Designer 

Select and click a table name and press TAB/DOWN ARROW to add/edit fields. Navicat will predict field types 

according to field names you entered.  
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INTEGER/int/int4/NUMBER 

 suffix "id", "no" (if it is the first column, it will be predicted as a primary key) 

 suffix "num" 

 "qty", "number" 

 exactly "age", "count" 

DECIMAL(10,2)/decimal(10,2)/NUMBER/REAL/money 

 suffix "price", "cost", "salary" 

FLOAT/double/float8/NUMBER/REAL/float 

 "size", "height", "width", "length", "weight", "speed", "distance" 

DATE/datetime/date/TEXT/datetime2 

 "date", "time" 

VARCHAR(255)/varchar(255)/VARCHAR2(255)/TEXT 

 other field names 

Enter * before the field name to recognize as primary key. e.g. *itemNo:int. 

Enter : between field name and field type to custom field type, e.g. itemName:varchar(255). 

Reorder Field 

Select a table in Diagram Canvas, then press and hold the SHIFT key. Use  to drag the field to a desired location. 

Delete Field 

Select a table in Diagram Canvas, then press and hold the SHIFT key. Use  to drag the desired field out of the 

table. 

Add Vertex to Foreign Key/Line/Arrow 

Select a foreign key/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on it to add vertex. 

Delete Vertex on Foreign Key/Line/Arrow 

Select a foreign key/line/arrow in Diagram Canvas. Press and hold the SHIFT key and click on the vertex. 

Switch to Hand Mode 

Press and hold the SPACE key, then move the diagram. 
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Select a Page in Print Preview 

Press and hold the SHIFT key, then point to a page to show the page number. 

Press and hold the SHIFT key, then click a page to jump to the corresponding page in Diagram Canvas. 
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Chapter 9 - Debugger (Available only in 

Non-Essentials Edition) 

About Debugger 

Navicat provides two code debuggers: Oracle PL/SQL Debugger and PostgreSQL PL/pgSQL Debugger. With the 

debuggers, you can toggle breakpoints, fetch call stacks, view variable values, trace the code, etc. 

Oracle PL/SQL Debugger 

Oracle PL/SQL Debugger provides step-by-step code debugging for functions, procedures, packages and queries. To 

launch the debugger, click the  Debug button in the designer of the mentioned objects. 

  

You can perform the most commonly used actions for debugging on the toolbar or menu: 

Button Description 

 Run Start running code in debug mode. Enter the Input Parameters if necessary. The 

debugger executes your code until the end of the code or the next breakpoint is reached. 

Keyboard shortcut: F9 

 Step Over Resume the execution. The current line will be executed. If the line is a procedure or 

function call, it will bypass the procedure or function. The counter will then move to the 

next line of code. Keyboard shortcut: F10 

 Step In Resume the execution. The current line will be executed. If the line is a procedure or 

function call, the counter goes to the first statement in the procedure or function. 

http://192.168.1.247/online_manual/en/navicat/win_manual/images/debuggerRepositionOracle.png
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Otherwise, the counter will move to the next line of code. Keyboard shortcut: F11 

 Step Out Resume the execution. The remaining part of the code within the current procedure or 

function will be executed. Subsequently, the counter will jump to the line which is just 

after the caller of the procedure or function. Keyboard shortcut: SHIFT+F11 

 Step End Resume the execution. The counter will jump to the last line of the procedure or function. 

 Stop Stop stepping the code. The execution will stop and cannot resume it. 

The Code pane shows the code of the procedure or function. You can add/remove breakpoints for debugging by 

clicking  in the grey area beside each statement. To add a variable to the watch list, right-click the highlighted code 

and choose Add to Watch List. 

The Call Stack pane displays a list of procedures and functions as they are called. To jump to a procedure or function, 

right-click it and choose Goto Function. 

The Breakpoints pane displays all the breakpoints which allowing you to delete, enable or disable breakpoints. To 

enable/disable a breakpoint, check/uncheck the check box. Also, you can delete a breakpoint or all breakpoints, 

right-click a breakpoint and choose Remove Breakpoint or Remove All Breakpoints. To jump to the line of a 

breakpoint, right-click it and choose Goto Function. 

The Local Variables pane displays all local variables and their values. Click on a value in the Value column to edit. To 

add a variable to the watch list, right-click it and choose Add to Watch List. 

The Parameters pane displays the inputted parameters. To add a parameter to the watch list, right-click it and choose 

Add to Watch List. 

The Watch List pane displays information about the variables being watched, allowing you to add, delete or edit watch 

variables. To add a watch variable, right-click anywhere on the pane and choose Add Variable. Then, enter the 

Variable Name. Click on a value in the Value column to edit. To delete a watch variable or all watch variables, 

right-click a variable and choose Remove Variable or Remove All Variables. 

The Log pane displays the message log when debugging the code and the results after the function or procedure has 

completed the execution. 

PostgreSQL PL/pgSQL Debugger 

PostgreSQL PL/pgSQL Debugger provides step-by-step code debugging for PL/pgSQL functions. To launch the 

debugger, click the  Debug button in the function designer. 
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You can perform the most commonly used actions for debugging on the toolbar or menu: 

Button Description 

 Run Start running code in debug mode. Enter the Input Parameters if necessary. The 

debugger executes your code until the end of the code or the next breakpoint is reached. 

Keyboard shortcut: F9 

 Step Over Resume the execution. The current line will be executed. If the line is a function call, it 

will bypass the function. The counter will then move to the next line of code. Keyboard 

shortcut: F10 

 Step In Resume the execution. The current line will be executed. If the line is a function call, the 

counter goes to the first statement in the function. Otherwise, the counter will move to 

the next line of code. Keyboard shortcut: F11 

 Step Out Resume the execution. The remaining part of the code within the current function will be 

executed. Subsequently, the counter will jump to the line which is just after the caller of 

the function. Keyboard shortcut: SHIFT+F11 

 Stop Stop stepping the code. The execution will stop and cannot resume it. 

The Code pane shows the code of the function. You can add/remove breakpoints for debugging by clicking  in the 

grey area beside each statement. 

The Call Stack pane displays a list of functions as they are called. 

The Breakpoints pane displays all the breakpoints. You can delete a breakpoint or all breakpoints, right-click a 

breakpoint and choose Remove Breakpoint or Remove All Breakpoints. To jump to the line of a breakpoint, 

right-click it and choose Goto Function. 

The Local Variables pane displays all local variables and their values. Click on a value in the Value column to edit. 

The Parameters pane displays the inputted parameters. 
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The Log pane displays the message log when debugging the code and the results after the function has completed the 

execution. 

  



 95 

 

Chapter 10 - Data Migration Tools 

About Data Migration Tools 

Navicat provides a number of powerful tools for working with data, including Import Wizard, Export Wizard, Data 

Transfer, Data Synchronization, Structure Synchronization, Dump SQL File and Execute SQL File. With those tools, 

you can migrate your data between different servers, databases and formats easily. 

Import Wizard 

About Import Wizard 

Import Wizard allows you to import data to tables from CSV, TXT, XML, DBF and more. You can save your settings as 

a profile for future use or setting automation tasks. To open the Import Wizard window, click  Import Wizard from 

the object toolbar. 

Note: Navicat Essentials edition only supports to import text-based files, such as TXT, CSV, XML and JSON. 

Hint: You can drag a supported file to the Table's Objects tab or a database/schema in the Navigation pane. Navicat 

will pop up the Import Wizard window automatically. If an existing table is highlighted, Navicat will import the file to the 

highlighted table. Otherwise, it will import the file to a new table. 

Choose File Format 

Select one of the available import types for the source file. 

Choose Source File 

Browse the source file name. The file extension in the Import from text box changes according to the selected import 

type in the first step. Select the Encoding for the source file.  

Note: You can select more than one file to import. 

Choose Delimiter - TXT, CSV, XML 

TXT, CSV 

Record Delimiter 

Specify the record separator of the file. 

Delimited 

Import the text file with delimited format. 

Field Delimiter, Text Qualifier 
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Specify the field separator and the character that encloses text values. 

Fixed Width 

Import the text file with fixed-width format. To delimit the source column bounds, click on the desired position to create 

a break line. Simply drag it to move it or double-click it to remove it. 

 

XML 

Tag that identifies a table row 

Define a tag to identify table rows. 

Consider tag attributes as table field 

For example: 

<row age="17"> 

<id>1</id> 

<name>sze</name> 

</row> 

With this option is on, Navicat will recognizes "age" as a table field together with "id" and "name", otherwise, only "id" 

and "name" will be imported as table fields. 

Note: Navicat does not support multiple level of XML file. 

Choose Additional Options - TXT, CSV, XML 

The following options depend on the file format chose in the first step. 

Field Name Row 

Indicate which row should Navicat recognize as column titles. 
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First Data Row 

Indicate which row should Navicat start reading the actual data. 

Last Data Row 

Indicate which row should Navicat stop reading the actual data. 

Note: If no column titles are defined for the file, enter 1 for First Data Row and 0 for Field Name Row. 

Date Order, Date Delimiter 

Specify the format for date and the date separator. 

Decimal Symbol 

Specify the decimal separator for decimal number. 

Time Delimiter 

Specify the time separator. 

DateTime Order 

Specify the order of date and time. 

Binary Data Encoding 

Set binary data are imported as Base64 encoded or no encoding in the file. 

Choose Target Table 

You are allowed to define a new table name or choose to import into an existing table from the drop-down list. 

Note: If you type a new table name in Target Table, the box in New Table will be checked automatically. 

 

For importing multiple tables, all tables will be shown in the list. 

 

Adjust Field Structures and Map Fields 

Navicat will make assumption on the field types and length in the source table. You are allowed to choose desired type 

from the drop-down list. 

Hint: For importing multiple tables, select other tables from the Source Table drop-down list. 
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If you are importing data into existing tables, you might need to map the source field names manually to the destination 

table or right-click and choose Smart Match All, Direct Match All and Unmatch All from the pop-up menu for quick 

mapping. 

 

 

 

Choose Import Mode 

Select the import mode that defines how the data being imported. 

 

Hint: To activate the remaining options, you must enable Primary Key in the previous step. 

 

Click the Advanced button for more settings. The following options depend on the connection server type. 
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Run multiple queries in each execution 

Check this option if you want to run multiple queries in each execution. 

Use extended insert statements 

Insert records using extended insert syntax. 

Example: 

INSERT INTO `users` VALUES ('1', 'Peter McKindsy', '23'), ('2', 'Johnson Ryne', '56'), ('0', 'Katherine', '23'); 

Use empty string as NULL 

Import NULL value if the source data field contains empty string. 

Use Foreign Key constraint 

Add foreign key if there is foreign key relations between tables. 

Continue on error 

Ignore errors that are encountered during the import process. 

Create Auto Increment Fields 

Create auto increment fields during the import process. 

Note: Support only when the file type is Paradox file or DBase file. 

Import Deleted Records 

Import the deleted records in the DBase file during the import process. 

Note: Support only when the file type is DBase file. 

Save and Start Import 

Click the Start button to begin the import process. The wizard will display the import progress, execution time, and 

success or failure messages.  

After the import process finished, you can click the Log button to open the log file. 

Hint: Click the Save button to save your settings as a profile. 
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Export Wizard 

About Export Wizard 

Export Wizard allows you to export data from tables, views, or query results to any available formats. You can save 

your settings as a profile for future use or setting automation tasks. To open the Export Wizard window, click Export 

Wizard from the object toolbar. 

Note: Navicat Essentials edition only supports to export text-based files, such as TXT, CSV, HTML, XML and JSON. 

Choose File Format 

Select one of the available export formats for the target file. 

Choose Saving Path 

You can set the exported file name and location in this step. 

Check the box next to the object name that you want to export. If an existing object is highlighted in the object pane, it 

will be checked automatically and assigned a default file name and location. The file extension in the Export to text box 

changes according to the selected export type in the first step.  

Note: For exporting query results, ensure the query is saved before running Export Wizard. Otherwise, no source 

object displayed in here. 

 

 

Select All Button Description 

Select All / Unselect All Select / unselect all source objects. 

Export selected to same file Export the selected objects into the same target file. When the 
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file format is Excel, each object will be exported as a sheet in 

the Excel file. 

Export selected to same 

folder 

Export the selected objects into the same directory. 

 

Advanced Button Description 

Encoding Select the encoding for the exported file. 

Add timestamp Check this option if you want your file name specifies the 

timestamp of the export is run. Select the date/time format from 

the drop-down menu. 

 

Choose Columns for Export 

You can select what fields to export. All the fields are selected in the list by default. If you want to omit some fields to be 

exported, uncheck the All Fields option first and then uncheck those fields in the list. 

Note: For exporting query result, the wizard will skip this step. 

Choose Additional Options 

The following options depend on the file format chose in the first step. 

Include column titles 

Field names will be included into the exported file if this option is on. 

Append 

If you selected the Export selected to same file option in the second step, check this option to append records in the 

exported file. 

Continue on error 

Ignore errors that are encountered during the export process. 

Use Attributes Format in XML 

Attributes Format 

<RECORDS> 

<RECORD OrderNo="1003" ItemNo="1" PartNo="1313" Qty="5" Discount="0"></RECORD> 

<RECORD OrderNo="1004" ItemNo="1" PartNo="1313" Qty="10" Discount="50"></RECORD> 

</RECORDS> 

Non-Attributes Format 

<RECORDS> 

<RECORD> 

    <OrderNo>1003</OrderNo> 
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    <ItemNo>1</ItemNo> 

    <PartNo>1313</PartNo> 

    <Qty>5</Qty> 

    <Discount>0</Discount> 

</RECORD> 

<RECORD> 

    <OrderNo>1004</OrderNo> 

    <ItemNo>1</ItemNo> 

    <PartNo>1313</PartNo> 

    <Qty>10</Qty> 

    <Discount>50</Discount> 

</RECORD> 

</RECORDS>  

Record Delimiter, Field Delimiter, Text Qualifier 

Specify the record separator, the field separator and the character that encloses text values. 

Date Order, Date Delimiter 

Specify the format for date and the date separator. 

Zero Padding Date 

Add a leading zero to pad days and months to two digits if necessary. 

Time Delimiter 

Specify the time separator. 

Decimal Symbol 

Specify the decimal separator for decimal number. 

Binary Data Encoding 

Set binary data are exported as Base64 encoded or no encoding in the file. 

Save and Start Export 

Click the Start button to begin the export process. The wizard will display the export progress, execution time, and 

success or failure messages. 

After the export process finished, you can click the Open button to open the exported file or the log file. 

Hint: Click the Save button to save your settings as a profile. 
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Data Transfer (Available only in Non-Essentials Edition) 

About Data Transfer 

Navicat allows you to transfer objects from one database and/or schema to another, or to a sql file. The target database 

and/or schema can be on the same server as the source or on another server. To open the Data Transfer window, 

select Tools -> Data Transfer from the menu bar. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Hint: You can drag tables to a database/schema in the Navigation pane. If the target database/schema is within the 

same connection, Navicat will copy the table directly. Otherwise, Navicat will pop up the Data Transfer window. 

Choose Connections & Advanced Options (Step 1) 

Choose Source and Target Connections 

In the General tab, define connections, databases and/or schemas for Source Database and Target Database. You 

can click  to swap the source and target settings. 

You can also transfer your selected database objects directly to a text file. Select the File option. Choose the target 

path, SQL Format and Encoding for the file. 

Note: Navicat Premium supports transferring table with data across different server types, e.g. from MySQL to Oracle. 

Choose Advanced Options 

In the Options tab, set the advanced options. The options depend on the source and target connection server types 

and sort in ascending order. 

Continue on error 

Ignore errors that are encountered during the transfer process. 

Convert object name to 

Check this option if you require convert object names to Lower case or Upper case during the process. 

Create records 

Check this option if you require all records to be transferred to the destination database and/or schema. 

Create tables 
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Check this option if you want to create tables in the target database. Suppose this option is unchecked and tables 

already exist in the target database/schema, then all data will be appended to the destination tables. 

Create target database/schema if not exist 

Create a new database/schema if the database/schema specified in the target server does not exist. 

Drop target objects before create 

Check this option if database objects already exist in the target database and/or schema, the existing objects will be 

deleted once the data transfer starts. 

Drop with CASCADE 

Check this option if you want to drop the dependent database objects with the cascade option. 

Include auto increment 

Include auto increment in the table with this option is on. 

Include character set 

Include character set in the table with this option is on. 

Include checks 

Include checks in the table with this option is on. 

Include engine/table type 

Include table type with this option is on. 

Include excludes 

Include exclusion constraints in the table with this option is on. 

Include foreign key constraints 

Include foreign keys in the table with this option is on. 

Include indexes 

Include indexes in the table with this option is on. 

Include other table options 

Include other options in the table with this option is on. 

Include rules 
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Include rules in the table with this option is on. 

Include triggers 

Include triggers in the table with this option is on. 

Include uniques 

Include uniques in the table with this option is on. 

Lock source tables 

Lock the tables in the source database and/or schema during the data transfer process.  

Lock target tables 

Lock the tables in the target database and/or schema during the data transfer process.  

Use complete insert statements 

Insert records using complete insert syntax. 

Example: 

INSERT INTO `users` (`ID Number`, `User Name`, `User Age`) VALUES ('1', 'Peter McKindsy', '23'); 

INSERT INTO `users` (`ID Number`, `User Name`, `User Age`) VALUES ('2', 'Johnson Ryne', '56'); 

INSERT INTO `users` (`ID Number`, `User Name`, `User Age`) VALUES ('0', 'katherine', '23'); 

Use DDL from SHOW CREATE TABLE 

If this option is on, DDL will be used from SHOW CREATE TABLE. 

Use DDL from sqlite_master 

If this option is on, DDL will be used from the SQLITE_MASTER table. 

Use delayed insert statements 

Insert records using DELAYED insert SQL statements. 

Example: 

INSERT DELAYED INTO `users` VALUES ('1', 'Peter McKindsy', '23'); 

INSERT DELAYED INTO `users` VALUES ('2', 'Johnson Ryne', '56'); 

INSERT DELAYED INTO `users` VALUES ('0', 'katherine', '23'); 

Use extended insert statements 
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Insert records using extended insert syntax. 

Example: INSERT INTO `users` VALUES ('1', 'Peter McKindsy', '23'), ('2', 'Johnson Ryne', '56'), ('0', 'Katherine', '23'); 

Use hexadecimal format for BLOB 

Insert BLOB data as hexadecimal format. 

Use single transaction 

Check this option if you want to use a single transaction during the data transfer process. 

Use transaction 

Check this option if you want to use transaction during the data transfer process. 

Choose Objects & Start Data Transfer (Step 2) 

All the database objects are selected in the Database Objects list by default. If you do not want some database objects 

to be transferred, uncheck them. 

 

 

 

Only the checked database objects will be transferred. However, if you add any 

new database objects in the source database and/or schema after you create your 

data transfer profile, the newly added database objects will not be transferred 

unless you manually modify the Database Objects list. 

 

All the database objects being transferred to the target database/schema, all 

newly added database objects will also be transferred without amending the data 

transfer profile. 

Then, click the Start button to execute the data transfer process. The window will display the execution progress, 

execution time, and success or failure messages. 
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Data Synchronization (Available only in Non-Essentials Edition) 

About Data Synchronization 

Navicat allows you to transfer data from one database and/or schema to another with detailed analytical process. In 

other words, Navicat provides the ability for data in different databases and/or schemas to be kept up-to-date so that 

each repository contains the same information. To open the Data Synchronization window, select Tools -> Data 

Synchronization from the menu bar. 

All tables must contain primary keys and all table structures must be identical between the source and target. You 

could apply Structure Synchronization before Data Synchronization. 

You can save your settings as a profile for future use or setting automation tasks. To open a saved profile, click the 

Load Profile button and select a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Note: For Oracle server, BLOB, CLOB, NCLOB, LONG and LONG RAW data are skipped during the data 

synchronization process. TIMESTAMP primary key cannot synchronize (insert, update) with Database Link to 9i server. 

RAW primary key cannot synchronize (insert, update, delete) with Database Link to any server, without error. 

Hint: Navicat Premium and Navicat for MySQL support synchronizing between MySQL and MariaDB. 

Choose Connections & Comparing Options (Step 1) 

Choose Source and Target Connections 

In the General tab, define connections, databases and/or schemas for Source Database and Target Database. You 

can click  to swap the source and target settings. 

Choose Comparing Options 

In the Options tab, set the comparing options. 

Use transaction 

Rollback all data when error occurs. 

Show synchronization detail 

Check this option if you want to list the details process in the message log during the synchronization. 

Insert records, Delete records, Update records 

Check these options to compare such actions. 
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Choose Table Mapping (Step 2) 

In this step, only tables which contain identical table names between the source and target are mapped in the list by 

default. If you do not want some tables to be synchronized, disable them manually from the drop-down list. 

View Data Comparison Results (Step 3) 

After comparing data, the window shows the number of records that will be inserted, updated or deleted in the target 

tables. Uncheck the Show identical table and others option to hide the tables with identical data and the tables with 

different structures. All tables with different data and all actions are checked by default. Uncheck the tables or the 

actions you do not want to apply to the target. 

 

When you selected a table in the list, the bottom pane shows the data in source and target. Select an option from the 

list to show the differences. Values that differ between source and target are highlighted. Uncheck the records that you 

do not want to apply to the target. 

Option Description 

Difference Show all records that are different in source and target tables. 

Insert Only show the records that do not exist in the target table. 

Update Only show the records that exist in both source and target tables, 

but they have different values. 

Delete Only show the records that do not exist in the source table. 

Same Show the records that exist in both source and target tables and 

they have identical values. 

All Rows Show all records in source and target tables. 

 

Click the Deploy button to show the scripts of all selected tables and records. 



 109 

 

Edit & Execute Selected Scripts (Step 4) 

You can view all scripts that will be executed in the target database in the Deployment Script tab. 

Deployment Script Button Description 

Edit Open the Edit Deployment Script window to rearrange the order of the 

scripts. It is the same as clicking the Deployment Script button. 

Copy to clipboard Copy all scripts from the Deployment Script tab to the clipboard. 

Open in Query Editor Open a new query window and display the scripts. 

In the Edit Deployment Script window, use the arrow buttons to move the scripts. 

 

Check the Continue on error option to ignore errors that are encountered during the execution process if necessary. 

Then, click the Execute button to execute the scripts. The window will display the execution progress, execution time, 

and success or failure messages. 

Structure Synchronization (Available only in Non-Essentials 

Edition) 

About Structure Synchronization 

Navicat allows you to compare and modify the table structures and other objects with detailed analytical process. In 

other words, Navicat compares objects between two databases and/or schemas and states the differential in structure. 

To open the Structure Synchronization window, select Tools -> Structure Synchronization from the menu bar. 

You can save your settings as a profile for future use. To open a saved profile, click the Load Profile button and select 

a profile from the list. 

Hint: Profiles are saved under the Profiles Location. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. Navicat Premium and Navicat for MySQL support 

synchronizing between MySQL and MariaDB. 
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Choose Connections & Comparing Options (Step 1) 

Choose Source and Target Connections 

In the General tab, define connections, databases and/or schemas for Source Database and Target Database. You 

can click  to swap the source and target settings. 

Choose Comparing Options 

In the Options tab, set the database/schema comparing options. The options depend on the connection server type 

and sort in ascending order. 

Compare auto increment value 

Check this option if you want to compare the auto increment values of tables. 

Compare character set 

Check this option if you want to compare the character sets of tables. 

Compare checks 

Check this option if you want to compare checks. 

Compare definers 

Check this option if you want to compare the definers. 

Compare events 

Check this option if you want to compare events. 

Compare excludes 

Check this option if you want to compare table excludes. 

Compare foreign keys 

Check this option if you want to compare table foreign keys. 

Compare functions 

Check this option if you want to compare functions. 

Compare indexes 

Check this option if you want to compare indexes. 

Compare partitions 
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Check this option if you want to compare table partitions. 

Compare primary keys 

Check this option if you want to compare table primary keys. 

Compare rules 

Check this option if you want to compare rules. 

Compare sequences 

Check this option if you want to compare sequences. 

Compare tables 

Check this option if you want to compare tables. 

Compare tablespace and physical attributes 

Check this option if you want to compare tablespace and physical attributes. 

Compare triggers 

Check this option if you want to compare triggers. 

Compare uniques 

Check this option if you want to compare table uniques. 

Compare views 

Check this option if you want to compare views. 

Drop with CASCADE 

Check this option if you want to drop the dependent database objects with the cascade option. 

Start Comparison 

Click the Compare button to compare the source and target databases. 

View Structure Comparison Results (Step 2) 

After comparing structures, the tree view shows the differences between the source and target databases or schemas. 

All objects are checked in the tree view by default. Uncheck the objects you do not want to apply to the target. You can 

expand the table objects to view the detailed structure. 
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You can choose to group the objects in the tree views by object type or operation by selecting Group by object type or 

Group by operation. 

Operation Description 

 

Object exists in both source and target databases/schemas, but they have different 

definition. The target object will be modified based on the source object. 

 

Object does not exist in the target database/schema. It will be created in the target. 

 

Object does not exist in the source database/schema. The target object will be deleted. 

 

Object exists in both source and target databases/schemas and they have identical 

definition. No operation will be applied. 

When you selected an object in the tree view, the DDL Comparison tab shows the DDL statements of that object in the 

source and the target, and the Deployment Script tab shows the detailed SQL statements of the object that will be 

executed in the target databases. 

 

Click the Deploy button to show the scripts of all selected objects. 

Edit & Execute Selected Scripts (Step 3) 

You can view all scripts that will be executed in the target database in the Deployment Script tab. 
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Deployment Script Button Description 

Edit Open the Edit Deployment Script window to rearrange the order of the scripts. It 

is the same as clicking the Deployment Script button. 

Copy to clipboard Copy all scripts from the Deployment Script tab to the clipboard. 

Open in Query Editor Open a new query window and display the scripts. 

In the Edit Deployment Script window, use the arrow buttons to move the scripts. 

 

Check the Continue on error option to ignore errors that are encountered during the execution process if necessary. 

Then, click the Execute button to execute the scripts. The window will display the execution progress, execution time, 

and success or failure messages. 

Dump & Execute SQL File 

The Dump SQL File and Execute SQL File features allow you to dump your database, schema or tables to a SQL file 

or execute SQL files in your connection, database or schema. 

To dump a SQL file 

1. In the main window, right-click an opened database/schema or right-click the selected tables, and choose 

Dump SQL File -> Structure Only or Structure And Data. 

2. Browse the save location and enter a file name. 

3. Click Save. 

To execute a SQL file 

1. In the main window, right-click an opened connection, database or schema and choose Execute SQL File. 

2. Browse your SQL file, choose the encoding of the file and enable appropriate options. 

Option Description 
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Continue on error Ignore errors that are encountered during the execution process. 

Run multiple 

queries in each 

execution 

Execute multiple SQL statements at once. 

SET 

AUTOCOMMIT=0 / 

No Auto Commit 

Disable auto commit mode. 

3. Click Start. 

Hint: You can drag and drop a .sql file to an opened connection, database or schema in the Navigation pane. Navicat 

will pop up the Execute SQL File window automatically. 
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Chapter 11 - Automation (Available only in 

Non-Essentials Edition) 

About Automation 

Navicat allows you to automate executing jobs at one or more regular intervals. Automation can be created for Query, 

Backup, Data Transfer, Data Synchronization, Import and Export from databases. You can define a list of jobs to be 

performed within one batch job, either run it manually or at the specified time/periodically. In the main window, click  

Automation to open the automation object list. 

Hint: Batch Job files are saved under the Profiles Location. 

Create Batch Job (Step 1) 

Add Jobs to Batch Job 

In the bottom pane of the General tab, select the job type, and then browse the connection, database and/or schema to 

locate jobs if necessary. 

 

Move jobs from the Available Jobs list to the Selected Jobs list by double-clicking or dragging them. To delete the 

jobs from the Selected Jobs list, remove them in the same way. You are allowed to run profiles from different servers in 

a single batch job. 

To rearrange the sequence of the selected jobs, use the  Move Up or  Move Down buttons. 

If you want to backup whole server, you can select the connection and choose Backup Server xxx. 
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Exported files can be added to the batch job as mail attachment. Select the job in the Selected Jobs list and click  

Add Attachment or  Remove Attachment to add or remove the mail attachment. 

Set Email Notification 

Navicat allows you to generate and send personalized emails with results returned from a schedule. The results can be 

emailed to multiple recipients. Check the Send Email option in the Advanced tab and enter required information. 

From 

Specify email address of sender. For example, someone@navicat.com. 

To, CC 

Specify email addresses of each recipient, separating them with a comma or a semicolon (;). 

Subject 

Specify the email subject with customized format. 

Body 

Write email content. 

Host (SMTP Server) 

Enter your Simple Mail Transfer Protocol (SMTP) server for outgoing messages. 

Port 

Enter the port number you connect to your outgoing email (SMTP) server. 

Use authentication 

Check this option and enter User Name and Password if your SMTP server requires authorization to send email. 

Secure connection 

Specify the connection to use TLS, SSL secure connection or Never. 

Send Test Mail 

Navicat will send you a test mail indicating success or failure. 

Save / Run Batch Job 

Before setting schedule, click the  Save button to save the batch job. 

You can run the batch job manually by clicking the  Start button. The Message Log tab displays the execution 

progress, execution time, and success or failure messages. 
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Schedule Batch Job (Step 2) 

You can click  Set Task Schedule to set schedule for running a batch job and click  Delete Task Schedule to 

remove the schedule. 

"hour" and "minute" fields must be specified. If a field is left without a value, then all the values will be used. For 

example, if the "weekday" field is empty, then the system will treat the field to be entered with "0, 1, 2, 3, 4, 5, 6". Use 

commas to separate values. For example, "0, 1, 3, 6". Use hyphen, without spaces to indicate values. For example, 

"0-4".  

Example: The batch job will be executed at 6:30pm every weekday. 

 

Note: Please save the batch job before setting schedule. Passwords must be saved in the Connection window before 

running your schedule. 
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Chapter 12 - Backup & Restore (Available only in 

Non-Essentials Edition) 

About Backup & Restore 

A secure and reliable server is closely related to performing regular backups, as failures will probably occur sometimes 

- caused by attacks, hardware failure, human error, power outages, etc. 

Navicat provides a built-in backup and restore tool for users to backup/restore MySQL, PostgreSQL, SQLite and 

MariaDB database objects. For Oracle, users can use Oracle Data Pump feature. 

Built-in Backup & Restore Tool 

About Built-in Backup & Restore Tool 

The built-in backup & restore tool allows you to backup/restore database objects for your database. You can save your 

settings as a profile for future use or setting automation tasks. In the main window, click  Backup to open the 

backup object list. 

Hint: Backup files are saved under the Settings Location. To open the folder, right-click a backup file and choose Open 

Containing Folder. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. To backup Oracle, see Oracle Data Pump. 

Backup 

General Properties 

In this tab, you can view the server and database information. Enter a comment for the backup file if necessary. 

Object Selection 

In this tab, choose database objects you wish to backup. 

 

Only the checked database objects will be backed up. However, if you add any new 

database objects in the database and/or schema after you create your backup profile, 

the newly added database objects will not be backed up unless you manually modify the 

Objects list. 

 

All the database objects being backed up, all newly added database objects will also be 

backed up without amending the backup profile. 

Advanced Properties 

Note: The following options depend on the connection server type and sort in ascending order. 

Lock All Tables 
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Lock all objects while backup is being processed. 

Use Single Transaction (InnoDB only) 

If a table uses InnoDB storage engine, with this option is on, Navicat uses transaction before the backup process starts. 

Use specify file name 

Define your file name for backup. Otherwise, your backup file will be named with "YYYYMMDDhhmmss" format. 

Restore 

Restore feature will firstly drop the selected objects of the database, then recreate the new objects according to your 

backup. Finally, inserting the data. 

Restore a backup to an existing database/schema 

1. In the main window, open a database/schema. 

2. Click Backup and select an existing backup file. 

3. Click Restore Backup from the object toolbar. 

4. Choose the restore options and click Start. 

Restore a backup to a new database/schema 

1. Create and open a new database/schema. 

2. Click Backup. 

3. In the Objects tab, right-click anywhere and choose Restore Backup from. 

4. Browse the backup file. 

5. Choose the restore options and click Start. 

Hint: You can also restore Navicat Windows and macOS backups. 

Note: You must have Create, Drop and Insert privileges (MySQL/MariaDB or PostgreSQL) to run the restore. 

General Properties 

In this tab, you can view the target server and database information and the backup file information. 

Object Selection 

In this tab, choose database objects you wish to restore. 

Advanced Properties 
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Note: The following options depend on the connection server type, the backup file version and sort in ascending order. 

Continue on error 

Ignore errors that are encountered during the restore process. 

Create indexes 

Create indexes for the restored table with this option is on. 

Create tables 

Create tables during the restore process with this option is on. 

Create records 

Restore table records with this option is on. Otherwise, only table structures will be restored. 

Create triggers 

Create triggers for the restored table with this option is on. 

Empty table 

Delete all table records in the database/schema. 

Lock tables for write 

Lock the tables to prevent user to modify tables during the restore process. 

Insert auto increment values 

Insert auto increment values in the database/schema. 

Overwrite existing events 

Overwrite if events already exist in the database/schema. 

Overwrite existing functions 

Overwrite if functions already exist in the database/schema. 

Overwrite existing indexes 

Overwrite if indexes already exist in the database/schema. 

Overwrite existing sequences 

Overwrite if sequences already exist in the database/schema. 

Overwrite existing tables 
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Overwrite if tables already exist in the database/schema. 

Overwrite existing triggers 

Overwrite if triggers already exist in the database/schema. 

Overwrite existing types 

Overwrite if types already exist in the database/schema. 

Overwrite existing views 

Overwrite if views already exist in the database/schema. 

Run multiple queries in each execution 

Check this option if you want to run multiple queries in each execution, which will make the restore process faster. 

Use extended insert statements 

Check this option if you want to insert records using extended insert syntax. 

Example: INSERT INTO `users` VALUES ('1', 'Peter McKindsy', '23'), ('2', 'Johnson Ryne', '56'), ('0', 'Katherine', '23'); 

Use transaction 

Check this option if you want to rollback all data when error occurs. 

Extract SQL 

Extract SQL allows extracting SQL into a SQL file from your backup file. 

Extract a backup file that is in your database/schema 

1. Open a database/schema. 

2. Click Backup and select an existing backup file. 

3. Click Extract SQL from the object toolbar. 

4. Choose the Extract SQL options and click Start. 

5. Choose a path for the SQL file. 

Extract a backup file that is in any location 

1. Open any one of your databases/schemas. 

2. Click Backup. 

3. In the Objects tab, right-click anywhere and choose Extract SQL from. 
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4. Click Extract SQL from the object toolbar. 

5. Browse the backup file. 

6. Choose the Extract SQL options and click Start. 

7. Choose a path for the SQL file. 

Oracle Data Pump 

About Oracle Data Pump 

Data Pump includes two utilities: Data Pump Export and Data Pump Import. Data Pump Export is for unloading data 

and metadata into a dump file set. Data Pump Import is for loading an export dump file set into a target system. In the 

main window, click  Data Pump to open the data dump object list. 

To change the directory of the dump file set, right-click anywhere in the Objects tab and select Change Directory. 

Note: Data Pump is added in Oracle 10g or later. You require SYSDBA role to perform it. Dump file sets are stored in 

servers. 

Oracle Data Pump Export 

Before executing Data Pump Export, click the Generate SQL button to review the SQL statements. Then, you can click 

the Execute button to run the export process. 

You can save the Data Pump Export settings to a profile for future use. Data Pump Export profiles (.nbakora) are saved 

under the Settings Location. 

To show the hidden tabs (advanced options), check the Show Advanced Options option. 

General Properties 

Job Name 

Specify the name of the job. 

Mode 

Choose the export mode: FULL, TABLESPACE, SCHEMAS, TABLE. 

Content 

Choose which data to export. 

Export Data 

Select which objects to export. If you select the TABLE export mode, choose a schema in the Export Schema(Table 

Mode) drop-down list. 
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Dump Files 

Add dump files to the dump file set for the export. 

Metadata Filter 

In this tab, you can include or exclude specific objects types. 

Data Filter 

Query 

Specify a subquery that is added to the end of the SELECT statement for a table. 

Sample 

Specify a percentage for sampling the data blocks to be moved. 

Remap Data 

In this tab, you can specify remap functions for column data. 

Encryption 

Encryption Content 

Choose what to encrypt in the dump file set. 

Encryption Algorithm 

Choose a cryptographic algorithm to perform encryption. 

Encryption Mode 

Choose the encryption mode: Transparent, Encryption Password, Dual. 

Encryption Password 

If you choose the Encryption Password or Dual encryption mode, enter a password to encrypt data written to the dump 

file. 

Confirm Password 

Re-type your password. 

Advanced Properties 

Thread Number 

Enter the maximum number of worker processes that can be used for the job. 
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Reuse File 

Check this option to overwrite a preexisting file. 

Enable XMLCLOBS 

Check this option to enable data options for XMLCLOBS. 

Enable Cluster 

Check this option to start workers on instances usable by the job. 

Service Name 

Specify a service name that used to constrain the job to specific instances or to a specific resource group. 

Source Edition 

Specify the application edition. 

Version 

Specify the version of database objects to be extracted. 

Compression Type 

Specify which data to compress before writing to the dump file set. 

Transportable 

If you select the TABLE export mode, choose to never or always use the transportable option. 

Database Link 

Choose a database link to the remote database that will be the source of data and metadata for the job. 

Estimate 

Choose the estimate method for the size of the tables should be performed before starting the job. 

Access Method 

Choose an alternative method to unload data if the default method does not work. 

Log File Directory 

Choose the directory for saving the log file. 

Log File Name 

Enter the name of the log file. 
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Flashback SCN 

Enter the system change number (SCN) that used to enable the Flashback Query utility. 

Flashback Time 

Select a timestamp for finding a SCN. 

Oracle Data Pump Import 

Before executing Data Pump Import, click the Generate SQL button to review the SQL statements. Then, you can click 

the Execute button to run the import process. 

To show the hidden tabs (advanced options), check the Show Advanced Options option. 

General Properties 

Job Name 

Specify the name of the job. 

Mode 

Choose the import mode: FULL, TABLESPACE, SCHEMAS, TABLE. 

Content 

Choose which data to import. 

Table Exists Action 

Specify the action to be performed when data are loaded into a preexisting table. 

Import Data 

Select which objects to import. If you select the TABLE import mode, specify the schema name in the Schema text box. 

Dump Files 

Add dump files to the dump file set for the import. 

Network 

Database Link 

Choose a database link to the remote database that will be the source of data and metadata for the job. 

Estimate 

Choose the estimate method for the size of the tables should be performed before starting the job. 
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Flashback SCN 

Enter the system change number (SCN) that used to enable the Flashback Query utility. 

Flashback Time 

Select a timestamp for finding a SCN. 

Transportable 

If you select the TABLE export mode, choose to never or always use the transportable option. 

DataFile Path 

Specify the full file specification for a datafile in the transportable tablespace set.  

Filter 

Include/Exclude 

Include or exclude specific objects types. 

Query 

Specify a subquery that is added to the end of the SELECT statement for a table. 

Remap Data 

Remap Data 

Specify remap functions for column data. 

Remap DataFiles 

Specify the remapping for data files. 

Remap Objects 

Remap Schemas 

Specify the remapping for schemas. 

Remap TableSpaces 

Specify the remapping for tablespaces. 

Remap Tables 

Specify remap functions for tables. 
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Advanced Properties 

Thread Number 

Enter the maximum number of worker processes that can be used for the job. 

Reuse datafiles 

Check this option to reuse existing data files for creating tablespace. 

Skip unusable indexes 

Check this option to skip loading tables that have indexes that were set to the Index Unusable state. 

Streams configuration 

Check this option to import any general Streams metadata that may be present in the export dump file. 

Skip const error 

Check this option to skip constraint violations and continue the load. 

Disable append hint 

Check this option to prevent the append hint from being applied to the data load. 

Cluster 

Check this option to start workers on instances usable by the job. 

Service Name 

Specify a service name that used to constrain the job to specific instances or to a specific resource group. 

Target Edition 

Specify the database edition into which objects should be imported. 

Version 

Specify the version of database objects to be extracted. 

Access Method 

Choose an alternative method to unload data if the default method does not work. 

Partition Options 

Choose how to handle partitioned tables during the import operation. 

Encryption Password 
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Enter the password if an encryption password was specified in Data Pump Export. 

Segment Attributes, Segment Creation, Storage, OID, PCTSpace 

Choose the objects that the transformations to be applied to. 

Log File Directory 

Choose the directory for saving the log file. 

Log File Name 

Enter the name of the log file. 
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Chapter 13 - Server Security 

About Server Security 

Navicat provides a powerful tool for you to manage server user accounts and the privileges of database objects. All 

information of users and privileges are stored in the server. In the main window, click  User or  Role to open 

the user/role object list. 

MySQL/MariaDB User Management 

General Properties 

User Name 

Define a name for the user account. 

Host 

Enter a host name or an IP address where the user connected from. % means any host. 

Plugin 

Select the account authentication plugin for the user. 

Password 

Specify a login password for the user. 

Confirm Password 

Re-type the login password. 

Expire Password Policy 

Select the password expiration policy for the user account. 

Advanced Properties 

Max queries per hour, Max updates per hour, Max connections per hour 

Specify the maximum number of queries, updates, and connections that a user can perform during any given one-hour 

period. 0 means no limit. 

Max user connections 

Specify the maximum number of simultaneous connections that a user can make. 

Use OLD_PASSWORD encryption 
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Use the OLD_PASSWORD() function to generate a hash value for storing user password. 

SSL Type 

Specify the SSL/TLS-related options for the user account. 

ANY Require SSL encryption when the user connects. 

SPECIFIED Require a valid certificate when the user connects. Provide Certificate Issuer, Certificate 

Subject, or SSL Cipher. 

X509 Require a valid certificate when the user connects. 

Server Privileges 

In the grid, check the Granted option against the server privilege listed in Privilege to assign this user to have that 

privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All or Revoke All. 

Privileges 

To edit specific object privileges for the user, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the State option against the privilege listed in Privilege to assign this user to have that 

privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All or Revoke All. 

Oracle User & Role Management 

User Designer 

General Properties 

User Name 

Define a name for the user. 

Authentication 

Select the authentication method. 

PASSWORD Create a user. Specify a Password and re-type it in Confirm Password. Check the 

Expire Password option to force the user to change the password on the first attempted 

login. 

EXTERNAL Create a user authorised by an external service. Enter the certificate distinguished name 

or the Kerberos principal name in External Name. 

GLOBAL Create a user authorised by the enterprise directory service. Enter the X.509 name at the 
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enterprise directory service that identifies the user in X.500 Name. 

Default Table Space 

Choose the default tablespace for objects that the user creates. 

Temporary Table Space 

Choose the tablespace or tablespace group for the user's temporary segments. 

Profile 

Choose the profile that assign to the user. 

Lock Account 

Lock the user's account and disable access. 

Member of 

In the grid, check the Granted, Admin Option or As Default option against the role listed in Role Name to assign this 

user to be a member of the selected role. 

Quotas 

In the grid, specify the maximum amount of space that the user can allocate in the tablespaces. Enter the Quota and 

choose the Unit. Unlimited lets the user allocate space in the tablespace without bound. Multiple tablespaces can be 

set. 

Server Privileges 

In the grid, check the Granted or Admin Option option against the server privilege listed in Privilege to assign this 

user to have that privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All, Grant All With 

Grant Option or Revoke All. 

Privileges 

To edit specific object privileges for the user, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

user to have that privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All, Grant 

All With Grant Option or Revoke All. 
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Role Designer 

General Properties 

Role Name 

Define a name for the role. 

Authentication 

Select the authentication method. 

PASSWORD Create a role. Specify a Password and re-type it in Confirm Password. 

EXTERNAL Create a role authorised by an external service. 

GLOBAL Create a role authorised by the enterprise directory service. 

NOT IDENTIFIED Create a role without a password. 

Member of 

In the grid, check the Granted or Admin Option option against the role listed in Role Name to assign this role to be a 

member of the selected role. 

Members 

In the grid, check the Granted or Admin Option option against the user listed in Member to assign the selected user to 

be a member of this role. 

Server Privileges 

In the grid, check the Granted or Admin Option option against the server privilege listed in Privilege to assign this role 

to have that privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All, Grant All With 

Grant Option or Revoke All. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted option against the privilege listed in Privilege to assign this role to have that 

privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All or Revoke All. 

Maintain User 

Navicat provides a complete solution for maintaining Oracle users. 

1. In the main window, select users in the Objects tab. 
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2. Right-click the selected users. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

Option Description 

Expire Password Set the password of the user account to expire. 

Lock Account Lock the user account and disable access. 

Unlock Account Unlock the user account and enable access. 

 

PostgreSQL User, Group & Role Management 

User Designer 

Note: Users are available for PostgreSQL 8.0 or below. 

General Properties 

User Name 

Define a name for the user. 

User ID 

Specify an ID for the user. 

Password 

Specify a login password for the user. 

Confirm Password 

Re-type the login password. 

Password Encryption 

Choose whether the password is stored ENCRYPTED or UNENCRYPTED in the system catalogs. 

Expiry Date 

Set a datetime that the user's password will expire. If this option is omitted, the password will be valid for all time. 

Superuser 

Check this option to determine the user is a superuser. 

Can create database 

Check this option to allow the user to create databases. 
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Member of 

In the grid, check the Granted option against the group listed in Group Name to assign this user to be a member of the 

selected group. 

Privileges 

To edit specific object privileges for the user, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

user to have that privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All, Grant 

All With Grant Option or Revoke All. 

Group Designer 

Note: Groups are available for PostgreSQL 8.0 or below. 

General Properties 

Group Name 

Define a name for the group. 

Group ID 

Specify an ID for the group. 

Members 

In the grid, check the Granted option against the user listed in Member to assign the selected user to be a member of 

this group. 

Privileges 

To edit specific object privileges for the group, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted option against the privilege listed in Privilege to assign this group to have that 

privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All or Revoke All. 

Role Designer 

Note: Roles are available for PostgreSQL 8.1 or above. 
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General Properties 

Role Name 

Define a name for the role. 

Role ID 

Specify an ID for the role. 

Can login 

Check this option to allow the role to log in. 

Password 

Specify a login password for the role. 

Confirm Password 

Re-type the login password. 

Password Encryption 

Choose whether the password is stored ENCRYPTED or UNENCRYPTED in the system catalogs. 

Connection Limit 

Specify how many concurrent connections the role can make. -1 means no limit. 

Expiry Date 

Set a datetime that the role's password will expire. If this option is omitted, the password will be valid for all time. 

Superuser 

Check this option to determine the role is a superuser. 

Can create database 

Check this option to allow the role to create databases. 

Can create role 

Check this option to allow the role to create roles. 

Inherit privileges 

Check this option to determine the role inherits the privileges of roles it is a member of. 

Can update system catalog 
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Check this option to allow the role to update system catalog. 

Can replicate 

Check this option to allow the role to initiate streaming replication or put the system in and out of backup mode. 

Can bypass RLS 

Check this option to allow the role to bypasses every row-level security (RLS) policy. 

Member of 

In the grid, check the Granted or Admin Option option against the role listed in Role Name to assign this role to be a 

member of the selected role. 

Members 

In the grid, check the Granted or Admin Option option against the role listed in Member to assign the selected role to 

be a member of this role. 

Privileges 

To edit specific object privileges for the role, click  Add Privilege to open the window and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Check the object to show the grid on the right pane. 

3. In the grid, check the Granted or Grant Option option against the privilege listed in Privilege to assign this 

role to have that privilege. To grant or revoke all privileges, right-click on the grid and choose Grant All, Grant 

All With Grant Option or Revoke All. 

SQLite User Management 

Note: By default, a SQLite database does not require user authentication (no-authentication-required database). After 

you created a user, the database will be marked as requiring authentication (authentication- required database). Then, 

user need to provide username and password when connecting to the database file. 

General Properties 

User Name 

Define a name for the user account. 

Password 

Specify a login password for the user. 

Confirm Password 
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Re-type the login password. 

Administrator 

Check this option to give the admin privilege to the user. 

Privilege Manager 

Besides setting privileges in each user, Privilege Manager provides another view on privileges in a connection and its 

database objects. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

To add privileges, click Privilege Manager from the user object toolbar and follow the steps below: 

1. Expand the node in the tree view until reaching to the target object. 

2. Choose the object and click  Add Privilege to open the window. 

3. Check the user on the left pane. 

4. In the grid, check the relevant options against the privileges listed in Privilege to assign the selected user to 

have that object privilege. 
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Chapter 14 - Other Advanced Tools 

Server Monitor (Available only in Non-Essentials Edition) 

Navicat provides Server Monitor to view properties of selected servers. Select Tools -> Server Monitor and select 

the preferred server type from the menu bar. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

Process List 

This tab displays a list of processes from all selected servers. The process list provides the following detailed 

information. It depends on the database type you are chosen. 

 Server name that is given while setting the connection. 

 Process ID on the server. 

 Serial number of the process. 

 Current user who log in to the server. 

 Host from which the user is connected. 

 Database that the user is currently used. 

 Last command that was issued by the user. 

 Time, state and info of the process. 

 CPU time and state of the process. 

If you want to take action on auto-refreshing the process list in assigned seconds, choose View -> Set Auto Refresh 

Time and enter a refresh time value. To enable or disable the Auto Refresh feature, choose View -> Auto Refresh. 

Note: Effect will take once you assign the value. 

To set a selected process always show on the top of the grid, choose View -> On Top. To cancel this setting, select the 

process and choose View -> Cancel On Top. 

To stop a selected process, click the  End Process button. 

Variables 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

This tab displays a list of all server variables and their values. 
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You can edit MySQL, MariaDB and Oracle variable values here. Click  or press CTRL+ENTER to open an editor for 

editing. 

Status 

This tab displays a list of all server status and their values. 

Virtual Grouping (Available only in Non-Essentials Edition) 

Virtual Group aims to provide a platform for logical grouping objects by categories, so that all objects are effectively 

preserved. It can be applied on Connection, Table, View, Function, Query, Backup, Automation and Model. 

Hint: The vgroup.json file is saved under the Profiles Location. 

If you want to hide the group structure, select View -> Navigation Pane -> Flatten Connection and select View -> 

Flatten Object List. 

Create a new group 

1. In the main window, right-click on the Navigation pane or the Objects tab and select New Group or Manage 

Group -> New Group. 

2. Enter a name for the new group. 

Move an object to a group 

1. In the main window, right-click an object and select Manage Group -> Move To. 

2. Select an existing group. 

Move an object to the top-level 

1. In the main window, right-click an object and select Manage Group -> Exclude From Group. 

Hint: You can also use the drag and drop method to move objects. 

Connection Colorings 

Navicat provides highlighting connections by colors for identifying connections and their database objects. It lets you 

immediately know which connection you're connected to when you working on database objects. The highlighted color 

displays in the Navigation pane and the menu bar or the tab of its object window. 

To highlight a connection, right-click a connection in the Navigation pane and select Color. 
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Find in Database/Schema (Available only in Non-Essentials 

Edition) 

Navicat provides a Find in Database/Schema feature offers searching table and view records or object structures 

within a database and/or schema. To open the Find in Database/Schema window, select Tools -> Find in 

Database/Schema from the menu bar. 

1. Select a target Connection, Database and/or Schema. 

2. Enter the search string in Find what. 

3. Choose to find Data or Structure in the Look in drop-down list. 

4. Choose the Search Mode: Contains, Whole Word, Prefix or Regular Expression. 

5. Check the Case Insensitive box to disable case sensitive search if necessary. 

6. When finding Structure, you can choose to search different objects: Tables, Views, Functions, Queries, 

Indexes, Triggers, Events and/or Materialized Views. 

7. Click the Find button and then double-click an object in the Find Results list to view the record or the 

structure. 

Print Structure (Available only in Non-Essentials Edition)  

Navicat allows you to view and print database, schema and table structures, including table names, field names, field 

types and other field properties. In the main window, right-click a database, a schema or tables and select Print 

Database or Print Schema or Print Tables. A structure report window will pop up. You can send the structures to 

printer or print it to other file formats, such as PDF, HTML. 
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Favorites (Available only in Non-Essentials Edition) 

Favorites are links to database objects that you visit frequently. By adding a path to your favorites list, you can go to 

that database objects with a single click, instead of having to navigate the connection, database and/or schema in the 

Navigation pane. 

Add a link to Favorites 

1. Open an object, e.g. table. 

2. Select File / Favorites -> Add to Favorites or press SHIFT+CTRL+#. If the object is opened in tabbed window, 

you can right-click the tab and select Add to Favorites. 

3. Enter Favorite Name and select Favorite ID if the Add to Favorites window pops up. 

Open an object from Favorites 

1. Select Favorites -> favorite_name or press CTRL+#. 

Remove links from Favorites 

 Select Favorites -> Clear Favorites -> favorite_name to remove a link. 

 Select Favorites -> Clear Favorites -> Clear All to remove all links from the favorites list. 

Note: # represents 0, 1, 2, 3, 4, 5, 6, 7, 8 or 9. 

Search Filter 

Navicat provides search filters for searching your objects in the Navigation pane, the Objects tab, the Model Designer 

window and other tree structures. 

In the Navigation pane or other tree structures, click on the tree to focus and enter a search string directly. If 

connections have opened in the Navigation pane, the filter will also apply to their database objects.  

In the Objects tab, click  and enter a search string in the Search text box. 

In the Model Designer window, simply enter a search string in the Search text box.  

You can remove the filter by deleting the search string. 
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Chapter 15 - Configurations 

Options Settings 

Navicat provides a complete user interface customization with various options for all tools. 

To open the Options window, choose Tools -> Options from the menu bar. 

General 

General 

Allow multiple Navicat instances 

Check this option to allow opening multiple instances of Navicat. Uncheck this item means that clicking on the Navicat 

shortcut will re-activate the running instance of Navicat and not launch a new copy. 

Allow opening multiple forms for same object 

Check this option to allow opening multiple instances of an object. 

Show objects under schema in navigation pane 

Display database objects using the tree structure in the Navigation pane. To expand a node, simply double-click it. 

Hint: Reopen the database/schema to take effect. 

Show toolbar caption 

Show text on toolbar buttons in sub-windows. Otherwise, only buttons will be presented. 

Hint: Restart Navicat to take effect. 

 

Show function wizard 

Display the function wizard (MySQL/MariaDB, Oracle or PostgreSQL) when you create a new function/procedure. 

Check for updates on startup 

Check this option to allow Navicat checks for new version when it starts. 

GUI Font 

Define the font and its size used by Navicat interface. 
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Hint: Restart Navicat to take effect. 

Anti Alias 

Check this option to improve the quality of the displaying fonts. 

Query 

Ask to save new queries/profiles before closing 

With this option is on, Navicat will prompt you to save new queries or profiles every time when you quit the relevant 

sub-window. 

Use Auto Save 

Save automatically after modifications in SQL Editor by defining the Auto Save Interval (s) (e.g. 30). 

Database Items 

Hint: Reopen the database/schema to take effect. 

Show system items (PostgreSQL) 

Check this option to show all the system objects such as information_schema and pg_catalog schemas. 

Show auto index (SQLite) 

Check this option to show auto index generated for SQLite table in the Index's Objects tab. 

Tabs 

Open new tab in 

Set new pop-up windows to open as: 

Option Description 

Main Window Open a new tab in the main window. 

Last Tab Window Open a new tab in the last opened window, or a new window if there isn't any 

opened windows. 

New Window Open a new window. 

On Startup 

Control what tabs appear when you launch Navicat: 

Option Description 

Open Objects tab only Open the Objects tab only, and no other tabs. 

Continue where you left off Open the Objects tab, and reopen the same tabs you were opened when you 
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last quit Navicat. 

Open a specific tab or set 

of tabs 

Open the Objects tab, and open the tabs you choose in Set Tabs. 

Hint: Restart Navicat to take effect. 

Editor 

General 

Use code completion (Available only in Non-Essentials Edition) 

When you type the . (dot) symbol between the object names, SQL Editor will offer you a pop-up list that showing some 

suggestions for the code completion. When you type the first character of words, SQL Editor will offer you a pop-up list 

that showing some suggestions for the word completion. 

See Code Completion. 

Show line number 

Display line numbers at the left side of the editor for easily reference. 

Use code folding 

Code folding allows codes to collapse as a block and only the first line displayed in the editor, see Code Folding. 

Use brace highlighting 

Highlight the pair of braces when your cursor moves to either one brace for easily reference, see Brace Highlight. 

Use syntax highlighting 

Syntax highlight helps viewing codes clearly. Codes are highlighted in SQL Editor with different colors and fonts 

according to the categories they belong to. This feature can be limited by setting the maximum file size (e.g. 10) in 

Disable if file size is larger than (MB) to increase performance. 

Use word wrap 

Enable the word wrap mode in the editor. 

Tab Width 

Enter the number of characters that a tab occupies, e.g. 5. 

Font and Colors 

Editor Font 

Define the font and its size used by editors. 
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Colors 

Format your SQL queries in SQL Editor with colored syntax highlighting for your SQL statements to improve readability. 

Set font colors to mark out different text fragments: Common, Keyword, String, Number, Comment and Background. 

Click on the color boxes and choose your desired color from the Color-Selection dialog window. 

Records 

Records 

Limit Records  records per page 

Check this option if you want to limit the number of records showed on each page in the table grid/foreign key data 

selection globally. Otherwise, all records will be displayed in one single page. 

Note: To adjust the settings for particular table, see Data Viewer. 

Auto Begin Transaction 

Check this option to start a new transaction automatically when changing records in the table grid. Otherwise, auto 

commit is on and you need click the  Begin Transaction button in Data Viewer to start a transaction manually. 

When starting a transaction in Data Viewer, you can use the  Commit or  Rollback buttons to commit or 

rollback the changes. See Data Viewer. 

Grid 

Grid Font 

Define the font and its size used by grid in Data Viewer. 

Display Format 

Data of types date, time and datetime can be formatted when displayed on data grids. Type the format here to change 

the format. If the formats are left blank, default format will be used. Default formats will be the system datetime formats. 

 

Formats are defined by constructing a string using these format specifiers: 

Date Time fields 



 147 

 

Specifier Represent 

c The date using the format given by the ShortDateFormat global variable, 

followed by the time using the format given by the LongTimeFormat global 

variable. The time is not displayed if the fractional part of the DateTime value 

is zero. 

d The day as a number without a leading zero (1-31). 

dd The day as a number with a leading zero (01-31). 

ddd The day as an abbreviation (Sun-Sat) using the strings given by the 

ShortDayNames global variable. 

dddd The day as a full name (Sunday-Saturday) using the strings given by the 

LongDayNames global variable. 

ddddd The date using the format given by the ShortDateFormat global variable. 

dddddd The date using the format given by the LongDateFormat global variable. 

m The month as a number without a leading zero (1-12). If the m specifier 

immediately follows an h or hh specifier, the minute rather than the month is 

displayed. 

mm The month as a number with a leading zero (01-12). If the mm specifier 

immediately follows an h or hh specifier, the minute rather than the month is 

displayed. 

mmm The month as an abbreviation (Jan-Dec) using the strings given by the 

ShortMonthNames global variable. 

mmmm The month as a full name (January-December) using the strings given by the 

LongMonthNames global variable. 

yy The year as a two-digit number (00-99). 

yyyy The year as a four-digit number (0000-9999). 

h The hour without a leading zero (0-23). 

hh The hour with a leading zero (00-23). 

n The minute without a leading zero (0-59). 

nn The minute with a leading zero (00-59). 

s The second without a leading zero (0-59). 

ss The second with a leading zero (00-59).  

t The time using the format given by the ShortTimeFormat global variable. 

tt The time using the format given by the LongTimeFormat global variable. 

am/pm The time using the 12-hour clock for the preceding h or hh specifier, followed 

by "am" for any hour before noon, or "pm" for any hour after noon. The am/pm 

specifier can use lower, upper, or mixed case, and the result is displayed 

accordingly. 

a/p The time using the 12-hour clock for the preceding h or hh specifier, followed 

by "a" for any hour before noon, or "p" for any hour after noon. The a/p 

specifier can use lower, upper, or mixed case, and the result is displayed 

accordingly.  

ampm The time using the 12-hour clock for the preceding h or hh specifier, followed 
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by the contents of the TimeAMString global variable for any hour before noon, 

or the contents of the TimePMString global variable for any hour after noon. 

/ The date separator character given by the DateSeparator global variable. 

: The time separator character given by the TimeSeparator global variable. 

'xx'/"xx" Characters enclosed in single or double quotes are displayed as-is, with no 

formatting changes. 

Format specifiers may be written in uppercase or lowercase letters; both produce the same result. 

Show Thousands Separator 

Check this option to show the thousands separator for numeric data. 

File Locations 

You can change the folder for different types of files. By default, most of the files are stored in Settings Location. 

However, some files and profiles are located in the Profiles Location path and all the log files are stored in the Logs 

Location path. 

File in Profiles Location Server Type File Extension 

Automation MySQL .nbatmysql 

Oracle .nbatora 

PostgreSQL .nbatpgsql 

SQLite .nbatsqlite 

MariaDB .nbatmariadb 

Premium (Cross Server) .nbatpremium 

Code Snippet All .nsnippet 

Data Synchronization MySQL .ndsymysql 

Oracle .ndsyora 

PostgreSQL .ndsypgsql 

SQLite .ndsysqlite 

MariaDB .ndsymariadb 

Data Transfer MySQL .ndtfmysql 

Oracle .ndtfora 

PostgreSQL .ndtfpgsql 

SQLite .ndtfsqlite 

MariaDB .ndtfmariadb 

Premium (Cross Server) .ndtfpremium 

Model All .ndm 

Structure Synchronization MySQL .nssymysql 

Oracle .nssyora 

PostgreSQL .nssypgsql 

MariaDB .nssymariadb 
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Virtual Grouping All vgroup.json - stores how the objects 

are  

 

Proxy 

Use Proxy 

Check this option to use proxy for the activation process. Choose the Proxy Type and enter Host, Port, User Name 

and Password. 

Environment 

OCI Environment (Available only for Oracle) 

OCI library (oci.dll) 

Specify the location for the OCI library (oci.dll) for Oracle connection. By default, it is set to the bundled one in Navicat 

installation folder. 

Hint: Restart Navicat to take effect. 

Oracle Instant Client is the simplest way to deploy a full Oracle Client application built with OCI, OCCI, JDBC-OCI, or 

ODBC drivers. It provides the necessary Oracle Client libraries in a small set of files. You can also download Oracle 

Client / Oracle Instant Client through - 

Oracle Client 

Oracle Instant Client 

Download the appropriate Instant Client packages for your platform and the CPU. All installations REQUIRE the Basic 

or Basic Lite package. Unzip the packages and set the path points to it. 

  

http://www.oracle.com/technetwork/database/enterprise-edition/downloads/index.html
http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html
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Chapter 16 - Commands (Available only in 

Non-Essentials Edition) 

Navicat Commands 

Navicat has some very useful command line processing options for those who want to execute certain database tasks 

in Terminal. 

Navicat Object Command Line 

Automation start_navicat -batchjob BatchJobName 

Backup 

(MySQL, PostgreSQL, 

SQLite and MariaDB) 

start_navicat -backup [ProfileName] -u NavicatID -p ProjectName -t ConnectionType -c 

ConnectionName -d DatabaseName -s SchemaName 

Data Synchronization start_navicat -datasync ProfileName -t ConnectionType 

Data Transfer start_navicat -datatransfer ProfileName -t ProfileType 

Export Materialized 

View Result 

(Oracle and 

PostgreSQL) 

start_navicat -exportmview ProfileName -u NavicatID -p ProjectName -t 

ConnectionType -c ConnectionName -d DatabaseName -s SchemaName 

Export Query Result start_navicat -exportquery ProfileName -u NavicatID -p ProjectName -t 

ConnectionType -c ConnectionName -d DatabaseName -s SchemaName 

Export Table start_navicat -export ProfileName -u NavicatID -p ProjectName -t ConnectionType -c 

ConnectionName -d DatabaseName -s SchemaName 

Export View Result start_navicat -exportview ProfileName -u NavicatID -p ProjectName -t ConnectionType 

-c ConnectionName -d DatabaseName -s SchemaName 

Query Execution start_navicat -query QueryName -u NavicatID -p ProjectName -t ConnectionType -c 

ConnectionName -d DatabaseName -s SchemaName 

Import start_navicat -import ProfileName -u NavicatID -p ProjectName -t ConnectionType -c 

ConnectionName -d DatabaseName -s SchemaName 

NavicatID - if the connection stores in Navicat Cloud, Navicat ID is required, e.g. user@example.com 

ProjectName - if the connection stores in Navicat Cloud, project name is required 

ConnectionType - type of the connection: MySQL, Oracle, PostgreSQL, SQLite, MSSQL or MariaDB  

ProfileType - type of the data transfer profile: MySQL, Oracle, PostgreSQL, SQLite, MSSQL, MariaDB or Premium 

Example: 

start_navicat -exportquery MyQueryExport1 -u test@navicat.com -p Project1 -t MySQL -c "MySQL 5.6" -d sakila  
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Chapter 17 - Hot Keys 

Navicat Hot Keys 

Navicat Main Window 

Keys Action 

CTRL+# (# represents 0 to 9) Open Favorites Link 

CTRL+H History Log 

CTRL+Q New Query 

F12 Show Only Active Objects 

CTRL+N New Object 

ER Diagram View 

Keys Action 

F5 Refresh 

ESC Select 

H Move Diagram 

R New Foreign Key 

SHIFT+DELETE Delete Selected Foreign Key 

CTRL+= or CTRL+Mousewheel Up Zoom In 

CTRL+- or CTRL+Mousewheel Down Zoom Out 

CTRL+0 Reset Zoom 

Common 

Keys Action 

SHIFT+CTRL+# (# represents 0 to 9) Add to Favorites 

F8 Navicat Main Window / Objects Tab 

CTRL+TAB or SHIFT+CTRL+TAB Next Window / Tab 

CTRL+Q New Query 

F1 Help 

Table Designer 

Keys Action 

CTRL+O Open Table 

CTRL+F Find Field 

F3 Find Next Field 

SHIFT+F3 Find Previous Field 

Data Viewer 

Keys Action 
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CTRL+D Design Object (Table, View, Materialized View) 

CTRL+Q Query Object (Table, View, Materialized View) 

CTRL+F Find Text 

F3 Find Next Text 

CTRL+G Go to Row 

CTRL+LEFT ARROW Move to First Column of Current Record 

CTRL+RIGHT ARROW Move to Last Column of Current Record 

CTRL+HOME Move to First Row of Current Column 

CTRL+END Move to Last Row of Current Column 

CTRL+PAGE UP or CTRL+UP ARROW Move to First Row of Current Screen 

CTRL+PAGE DOWN or CTRL+DOWN ARROW Move to Last Row of Current Screen 

CTRL+R Apply Filter / Apply Sort 

SHIFT+ARROW Select Cells 

CTRL+ENTER Edit Data with Opening Editor 

INSERT or CTRL+N Add Record 

CTRL+DELETE Delete Records 

CTRL+S Apply Record Changes 

ESC Discard Record Changes 

CTRL+T Stop Loading Data 

View / Materialized View Designer 

Keys Action 

CTRL+O Import SQL 

CTRL+E Switch to Definition 

CTRL+R Preview 

Query Designer 

Keys Action 

CTRL+O Open External SQL File 

CTRL+E Switch to Query Editor 

CTRL+R Run 

SHIFT+CTRL+R Run Selected 

CTRL+T Stop 

SQL Editor 

Keys Action 

CTRL+/ Comment / Uncomment Line 

CTRL+F Find Text 

F3 Find Next Text 

CTRL+= Zoom In 

CTRL+- Zoom Out 



 153 

 

CTRL+0 Reset Zoom 

Debugger 

Keys Action 

F9 Run 

F10 Step Over 

F11 Step In 

SHIFT+F11 Step Out 

Model 

Keys Action 

CTRL+D New Diagram in Model 

CTRL+P Print Diagram 

ESC Select 

H Move Diagram 

T New Table 

V New View 

R New Foreign Key 

A New Label 

N New Note 

I New Image 

L New Layer 

CTRL+B Bold Selected Table, View, Foreign Key or Shape 

CTRL+= or CTRL+Mousewheel Up Zoom In 

CTRL+- or CTRL+Mousewheel Down Zoom Out 

CTRL+0 Reset Zoom 
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Chapter 18 - Trace Logs 

Log Files 

Navicat provides number of log files to keep track on the actions have been performed in Navicat and they are located 

in the logs directory, e.g. Y:\.navicat\Navicat\MySQL\logs\. You are allowed to change the log files location under 

Options.  

File Description 

history.log Store all SQL statements of all the operations executed over databases and database 

objects in Navicat. To open the LogHistory.txt file in the History Log Viewer, select 

Tools -> History Log or press CTRL+H. 

Note: This log will be overwritten while Navicat is being restarted. 

cmdline.log Store information for Navicat command line process and all operations while running 

batch jobs. 

LogImport.txt Record detailed information on every error (indicating success or failure) that occurred 

during the import process. 

Note: This log will be overwritten on each import. 

History Log Viewer 

History Log Viewer shows the SQL statements that are executed or executing in Navicat. If you just want to display 

error messages, click  Show Error Only. You can also change the information shown by choosing from the View 

menu -  

 Show Date 

 Show Time 

 Show Server Name 

 Show Session ID 

 Show Connection Type 

 Show Execute Time 

Note: When you click  Pause, any actions that you do while history is paused will show after resuming. 



 155 

 

 


	Chapter 1 - Introduction
	About Navicat
	Installation
	End-User License Agreement

	Chapter 2 - User Interface
	Main Window
	Navigation Pane
	Object Pane
	Information Pane

	Chapter 3 - Navicat Cloud
	About Navicat Cloud
	Manage Navicat Cloud

	Chapter 4 - Connection
	About Connection
	General Settings
	SSL Settings
	SSH Settings
	HTTP Settings
	Advanced Settings
	Databases / Attached Databases Settings

	Chapter 5 - Server Objects
	About Server Objects
	MySQL / MariaDB
	Databases
	Tables
	Views
	Procedures / Functions
	Events
	Maintain Objects

	Oracle
	Schemas
	Tables
	Views
	Materialized Views
	Procedures / Functions
	Packages
	Recycle Bin
	Other Objects
	Maintain Objects

	PostgreSQL
	Databases & Schemas
	Tables
	Views
	Materialized Views
	Functions
	Types
	Foreign Servers
	Other Objects
	Maintain Objects

	SQLite
	Databases
	Tables
	Views
	Other Objects
	Maintain Objects


	Chapter 6 - Data Viewer
	About Data Viewer
	Grid View & Form View
	Use Navigation Bar
	Edit Records
	Sort / Find / Replace Records
	Filter Records
	Manipulate Raw Data
	Format Data View

	Assistant Editors
	Filter Wizard

	Chapter 7 - Query
	About Query
	SQL Editor
	SQL Builder (Available only in Non-Essentials Edition)
	Code Snippets (Available only in Non-Essentials Edition)
	Query Results
	Query Parameters
	Debug Oracle Query (Available only in Non-Essentials Edition)

	Chapter 8 - Model (Available only in Navicat Premium and Enterprise Edition)
	About Model
	Model Window
	Build Diagram
	Add Tables
	Add Views
	Add Foreign Keys
	Add Labels
	Add Notes
	Add Images
	Add Shapes
	Add Layers
	Work with Diagram Canvas

	Reverse Engineering
	Forward Engineering
	Synchronize to Database
	Export SQL

	Model Conversion
	Preview and Print Model
	Model Hints and Tips

	Chapter 9 - Debugger (Available only in Non-Essentials Edition)
	About Debugger
	Oracle PL/SQL Debugger
	PostgreSQL PL/pgSQL Debugger

	Chapter 10 - Data Migration Tools
	About Data Migration Tools
	Import Wizard
	About Import Wizard
	Choose File Format
	Choose Source File
	Choose Delimiter - TXT, CSV, XML
	Choose Additional Options - TXT, CSV, XML
	Choose Target Table
	Adjust Field Structures and Map Fields
	Choose Import Mode
	Save and Start Import

	Export Wizard
	About Export Wizard
	Choose File Format
	Choose Saving Path
	Choose Columns for Export
	Choose Additional Options
	Save and Start Export

	Data Transfer (Available only in Non-Essentials Edition)
	About Data Transfer
	Choose Connections & Advanced Options (Step 1)
	Choose Objects & Start Data Transfer (Step 2)

	Data Synchronization (Available only in Non-Essentials Edition)
	About Data Synchronization
	Choose Connections & Comparing Options (Step 1)
	Choose Table Mapping (Step 2)
	View Data Comparison Results (Step 3)
	Edit & Execute Selected Scripts (Step 4)

	Structure Synchronization (Available only in Non-Essentials Edition)
	About Structure Synchronization
	Choose Connections & Comparing Options (Step 1)
	View Structure Comparison Results (Step 2)
	Edit & Execute Selected Scripts (Step 3)

	Dump & Execute SQL File

	Chapter 11 - Automation (Available only in Non-Essentials Edition)
	About Automation
	Create Batch Job (Step 1)
	Schedule Batch Job (Step 2)

	Chapter 12 - Backup & Restore (Available only in Non-Essentials Edition)
	About Backup & Restore
	Built-in Backup & Restore Tool
	About Built-in Backup & Restore Tool
	Backup
	Restore
	Extract SQL

	Oracle Data Pump
	About Oracle Data Pump
	Oracle Data Pump Export
	Oracle Data Pump Import


	Chapter 13 - Server Security
	About Server Security
	MySQL/MariaDB User Management
	Oracle User & Role Management
	User Designer
	Role Designer
	Maintain User

	PostgreSQL User, Group & Role Management
	User Designer
	Group Designer
	Role Designer

	SQLite User Management
	Privilege Manager

	Chapter 14 - Other Advanced Tools
	Server Monitor (Available only in Non-Essentials Edition)
	Virtual Grouping (Available only in Non-Essentials Edition)
	Connection Colorings
	Find in Database/Schema (Available only in Non-Essentials Edition)
	Print Structure (Available only in Non-Essentials Edition)
	Favorites (Available only in Non-Essentials Edition)
	Search Filter

	Chapter 15 - Configurations
	Options Settings
	General
	Tabs
	Editor
	Records
	File Locations
	Proxy
	Environment

	Chapter 16 - Commands (Available only in Non-Essentials Edition)
	Navicat Commands

	Chapter 17 - Hot Keys
	Navicat Hot Keys

	Chapter 18 - Trace Logs
	Log Files


