
GDS2LayoutViewer 

【特徴】 

 GDS II ストリームファイル(*.gds, *.str)を読み込んで、図形を表示します。 

 レイヤー（最大 256 レイヤーまで対応）の名称、色、塗り潰しパターン及び表示・非表示切換え、が設定可能です。 

 X/Y 軸反転表示、回転表示（0, 90, 180, 270 度）が可能です。 

 テキスト表示・非表示切換えが可能です。 

 階層表示の切替え（1 階層のみ、１～2..10 階層まで、もしくは最大 1024 階層まで表示）が可能です。 

 ルーラーによるパターン上での測長（最大 100 個まで）が可能です。 

 図形上にマーカーを配置して、マーカーに対応したメモ（最大 200 個）を作成できます。メモは CSV ファイルに保存出来ます。 

 全体表示用の別ウィンドウにメイン画面と同じストラクチャを表示して、メイン画面で拡大表示している領域を枠線で表示します。 

 2 つのストリームファイルを読み込み、選択したストラクチャの差分を表示します。（差分は最大 32768 個まで表示） 

【制限事項】 

 STREAM フォーマット（GDS II）の DATATYPE には対応していません。 

 STREAM フォーマット（GDS II）の PATH TYPE 1(round-ended path)には対応していません。 

 STREAM フォーマット（GDS II）の NODE には対応していません。 

 SREF/AREF（ストラクチャ内に配置されている別のストラクチャ/アレイ）やテキストデータは 90 度刻みの回転［0, 90, 180, 270 度］のみ

対応しています。 

 STREAMフォーマット（GDS II）のUSER UNITが規定値から変更されている場合については動作検証が出来ていないため、座標や寸法

が正しく表示されない可能性があります。 

 マルチディスプレイ環境における動作では、ダイアログボックスがメインフォームから大きくずれた位置に表示されてしまう等の問題が

発生する可能性があります。 

【動作環境】 

Windows7(32bit/64bit)、及び Windows10(64bit)にて動作確認済みです。 

【インストール】 

 インストーラはありません。GDS2LV.exe 単体で動作しますので、GDS2LV.exe を任意のフォルダに保存してご使用下さい。 

必要に応じてショートカットをデスクトップ等に配置して下さい。 

※一度アプリケーションを起動すると GDS2LV.exe と同じフォルダに GDS2LV.ini が自動的に作成されます。 

 ⇒GDS2LV.ini はアプリケーションの各種設定情報を保存しています。 

【アンインストール】 

GDS2LV.exe と GDS2LV.ini を削除して下さい。  



【改訂履歴】 

Version 1.0.1 

 ･GDS2LayoutViewer を公開。 

Version 1.0.2 

 ･Windows のディスプレイ設定における『画面上のテキストやその他の項目のサイズ』変更を正しく反映するように修正。(メ

イン画面のラベルやボタンサイズ、リストボックスやダイアログにおけるフォントや図形のサイズ等) 

 ・レイヤー設定やコンフィグにおいて、レイヤーの色やラインの色として『黒』を選択した場合に、選択状態を示す赤色の枠

線が表示されない問題を修正。 

 ・ストラクチャ内に、要素図形数の多い(初期設定値で 10 万個以上)ストラクチャが回転・反転状態で引用されていた場合に、

引用されているストラクチャ内の図形が表示できなくなる不具合を修正。 

※GDS2LV.ini 内の ElementCountLimitToMakeAddressIndex の値を境に、図形描画のデータ処理方法を変更しているため。

(ElementCountLimitToMakeAddressIndex の初期設定値は 100000) 

 ・ファイル内のストラクチャ数が多い場合に、ファイル読込時のストラクチャ名サイズ計算(描画用)に時間が掛かり、ファイル

読込時間が極端に遅くなる問題を修正。 

・描画パフォーマンス改善のため、画面分割数(=並列処理数)、図形の描画可否判定方法、及び図形塗り潰し可否の判定方法を

変更。 

Version 1.1.1 

・画面のサイズによって右端もしくは下端の図形が表示されなくなる不具合を修正。 

・テキストデータが部分的に表示されない不具合を修正。 

・表示階層指定(0～9 層)時に、表示される階層が 1 階層ずれていた不具合を修正。 

・レイヤー設定の塗り潰しパターン選択において、一部の塗り潰しパターンが正しく反映されていなかった不具合を修正。 

・画面上のテキストサイズが既定値(100%)以外に設定されている場合に、ショートカットキー設定用仮想キーボードのボタン

表示位置がずれてしまう不具合を修正。 

・ストラクチャリストにフォーカスがある場合に、矢印キーにて表示ストラクチャを移動できるように変更。 

・ストラクチャ表示画面左上のプロパティ表示不具合を修正。同時にプロパティ表示からのコピー機能(ストラクチャ名等)を

削除。⇒ストラクチャ名は、右クリックメニューの『Copy StructureName』でコピー可能。 

・コンフィグ画面を表示した際に、ルーラー方向指定が選択されていない不具合を修正。 

・背景色が黒、レイヤー色が白の組合せで、図形を塗りつぶすことが出来ない問題を修正。 

・表示しているストラクチャをマウス左ボタンドラッグで移動する際に、移動した軌跡に残像が残ってしまう不具合を修正。 

(コンフィグ画面にて『Draw Outer with Mouse Drag』をチェックしていない場合) 

・レイヤー設定において、選択可能な色数を 125 色から 214 色に変更。(白と黒は選択色から除外。既存のテクノロジファイル

における色設定は近似色に自動変換) 

・アプリケーションが非アクティブの時は、マウスカーソルをハンドポイント(上向きの指さしカーソル)にして、マウスカー

ソルの移動に応答(座標検出、十字カーソル追随等)しないように変更。 

・マウス右ボタンドラッグ時に『Zoom in』『Zoom out』の文字がドラッグ枠の左上に表示されるように変更。 

・図形の表示最小サイズを変更する機能を追加。(コンフィグ画面にて設定可能) 

・描画パフォーマンス改善のため、画面分割数(=並列処理数)及び描画アルゴリズムを変更。 

・『比較モード』（２つのストリームファイルの選択したストラクチャを比較して差分を表示）を追加。 

・図面をクリックした際に、自動的にルーラーを作成する機能(Auto Ruler)を追加。 

・マウスカーソルを図形の辺に吸着する機能(Snap Cursor to Shape)を追加。(コンフィグ画面にて吸着強度を設定可能。マウ

スカーソル右上に図形のレイヤー情報を表示) 



・マウスカーソルが図形の辺に吸着している状態で、かつ吸着図形のレイヤーが塗り潰されていないかハッチブラシが OFF

の場合に、マウス左ボタンクリックしている間、吸着図形のレイヤーを塗り潰す機能を追加。(コンフィグ画面にて ON/OFF

切り替え可能) 

・レイヤーリストにおいて、レイヤー色を表示している四角形をマウス左ボタンでクリックしている間、レイヤーを塗り潰す

機能を追加。 

・カーソルスタイルの『Line+Ruler』を『XY Ruler』に変更して、ルーラー表示までの遅延時間を 0 秒に設定。 

・ショートカットキーやマウスホイールによる図形の拡大・縮小操作において、マウスのカーソル位置を中心にして図形を拡

大・縮小するように変更。 

・マウスドラッグによる画面スクロールにおいて、ドラッグ始点から垂直・水平方向±5°は移動方向を垂直・水平に制限するよ

うに変更。 

・表示階層が制限されていて SREF/AREF が枠線と名前のみで表示されている状態で、SREF/AREF が 1 倍以外の倍率に設定

されている時、SREF/AREF 名の下に倍率を表示するように変更。 

  



【基本的な使い方】 

※(未公開版も含めて)バージョンアップに伴い、メニューやツールバーの構成を変更している場合があります。 

以下の説明と実際の動作とで異なる部分があるかもしれませんので、予めご承知おき下さい。 

 

１．ストリームファイル（*.gds, *.str）の開き方 

『ファイルを開く』ダイアログを使うか、もしくはファイルのドラッグアンドドロップでストリームファイルを開きます。 

メインメニュー [File]->[File Open…] 

ツールボタン  

ショートカットキー（初期値） [CTRL]+[O]  

右クリックメニュー [File Open…] 

マウスによるドラッグアンドドロップ ストリームファイル（*.gds, *.str）をドラッグして、ウィンドウ内にドロップ 

 

２．ストラクチャの表示 

ストリームファイル（*.gds, *.str）を読み込むと、画面右側の『ストラクチャリスト』にストラクチャの一覧が表示されます。 

（表示順は、ストラクチャ内の図形要素の多い順となっています。⇒メインメニューか右クリックメニューから表示順を変更可能です。） 

このリストから、ストラクチャを選択すると、図形が表示されます。 

⇒ストリームファイルを開いたときには、ファイル内で図形要素数が最も多いストラクチャが自動的に選択され、表示されます。 

※画面左側の『レイヤーリスト』には、使用しているレイヤー（番号、名前、色及び塗りつぶしパターン、表示･非表示）の一覧が表示されます。 

 

 

 

  



３．レイヤー設定：（レイヤー名、色、塗りつぶしパターン、表示・非表示等） 

レイヤー設定ダイアログの表示： 

メインメニュー [Layer]->[Layer Setup…]  

ツールボタン  

レイヤーリスト レイヤー番号、レイヤー名、色・塗りつぶしパターンをダブルクリック 

 

a).  レイヤー毎の設定： [Color Pattern]タブ：左側のリストでレイヤーを選択して、レイヤー毎の設定を行います。 

 レイヤー名、visible（表示・非表示切り替え）、Color（色）, BrushStyle（塗りつぶしパターン）を設定します。 

 『All V』ボタン： 全レイヤー表示 

 『All NV』ボタン： 全レイヤー非表示 

 『Init』ボタン： レイヤー設定初期化。テクノロジファイル（*.tec）を再読み込みします。 

 『Apply』ボタン： 表示図形に反映 

 『OK』ボタン： 表示図形に反映してから、ダイアログを閉じます。 

 『Save Setup…』ボタン： テクノロジファイルを保存します。 

４．テクノロジファイル（*.tec）の読込：レイヤー設定情報 

事前に作成されたテクノロジファイル（*.tec）が存在する場合には、読み込んで設定を反映することが出来ます。 

①．新規にストリームファイルを開く場合： 

 読み込んだストリームファイルと同じフォルダに*.tec が 1 つだけ存在する場合には、レイヤー設定を自動的に読み込みます。 

 フォルダ内に*.tec が無い場合、もしくは複数存在する場合には前回終了時の*.tec を読み込みます。 

②．以前に読み込んだことのあるストリームファイル（直近２０個まで）を開く場合： 

 以前に読み込んだテクノロジファイルを読み込みます。 

メインメニュー [File]->[Load Technology File…] 

メイン画面左下ボタン [TecFile…] 

レイヤー設定ダイアログ レイヤー設定ダイアログを開き、ダイアログ左下の[Load Setup…]ボタン 

マウスによるドラッグアンドドロップ テクノロジファイル（*.tec）をウィンドウにドロップする。 

 テクノロジファイルが読み込まれると、メイン画面左側の『レイヤーリスト』にレイヤー設定が反映され、 

ストラクチャが既に表示されている場合には、読み込んだレイヤー設定により、図形が再描画されます。 

  



５．表示倍率変更、スクロール 

メインメニューやツールボタン、キーボードやマウス操作にて、図形の拡大/縮小、画面スクロール、及び全体表示が可能です。 

拡大表示： 

メインメニュー [View]->[Zoom In] 固定倍率（125%）で拡大 

ツールボタン 画面右下の『 』ボタン 固定倍率（125%）で拡大 

ショートカットキー（初期値） CTRL+Z 固定倍率（125%）で拡大 

マウスホイール（初期値） CTRL+ホイール回転（上方向） 固定倍率（125%）で拡大 

マウス操作 マウスの右ボタンを押しながら移動して範囲指定をする。 

マウスの動きが[↘][↗][↙]のいずれかの場合。 

ドラッグした範囲を拡大表示 

倍率＝画面幅（高さ）/ドラッグ幅（高さ） 

縮小表示： 

メインメニュー [View]->[Zoom Out] 固定倍率（80%）で縮小 

ツールボタン 画面右下の『 』ボタン 固定倍率（80%）で縮小 

ショートカットキー（初期値） SHIFT+Z 固定倍率（80%）で縮小 

マウスホイール（初期値） CTRL+ホイール回転（下方向） 固定倍率（80%）で縮小 

マウス操作 マウスの右ボタンを押しながら移動して範囲指定をする。 

マウスの動きが[↖]の場合。 

ドラッグした範囲を縮小表示 

倍率＝ドラッグ幅（高さ）/画面幅（高さ） 

画面スクロール： 

ショートカットキー（初期値） 矢印キーを使う 矢印キーと逆方向に図形が移動 

マウスホイール（初期値） ホイール回転でスクロール可能 縦スクロール。SHIFT キーで横スクロール 

マウス操作 マウス左ボタンを押しながら移動する（ドラッグ） ドラッグに連動して図形が移動 

全体表示： 

ストラクチャ全体を表示する。 

メインメニュー [View]->[Fit to Screen] 

ツールボタン 画面右下の『 』ボタン 

ショートカットキー（初期値） F 

右クリックメニュー [Fit to Screen』 

 

  



６．グリッド表示、テキスト表示切替え、塗りつぶし 

a). SREF 内の図形表示 

表示階層を切替えます。1層のみ⇔全階層(最大 1024 階層)  

  １層のみ：引用されているストラクチャは枠線と名前で表示します。 

  全階層表示：引用されているストラクチャに含まれる図形も描画します。(上限は 1024 階層) 

メインメニュー [View]->[Draw SREF Inside] 

ツールボタン  

ショートカットキー（初期値） CTRL＋F（1 層のみ） / SHIFT+F（全階層） 

b). テキスト表示 

図形中のテキストデータの表示 ON/OFF を切り替えます。 

 ＊テキストデータ表示ON時の表示スキップに関して『Display Skip Text…』にて設計可能です。 

メインメニュー [View]->[Draw Text Data] 

ツールボタン  

ショートカットキー（初期値） なし 

c). グリッド表示 

画面右上の『 』ボタンにてグリッド表示のON/OFF を切り替えます。 

＊グリッドの間隔については、『Grid and Ruler Direction…』にて設定可能です。 

メインメニュー [View]->[Draw Grid] 

ツールボタン  

ショートカットキー（初期値） なし 

d). ハッチの ON/OFF 

画面右上の『 』ボタンにて図形の塗りつぶしの ON/OFF を切り替えます。 

メインメニュー [View]->[Draw Hatch Brush] 

ツールボタン  

ショートカットキー（初期値） なし 

 

  



【表示補助機能】 

７．全体表示ウィンドウ、図形の回転、X 軸/Y 軸反転、情報表示 

a). 全体表示ウィンドウ： 

全体表示ウィンドウが開き、メイン画面上で表示している領域を枠線として点滅表示します。 

メインメニュー [Window]->[Bird’s-eye View Window] 

ツールボタン  

ショートカットキー（初期値） SHIFT+V 

b). 回転： 

図形が左に 90 度回転します。4回回転すると元に戻ります。 

メインメニュー [View]->[Rotate] 

ツールボタン  

ショートカットキー（初期値） なし 

c). Y 方向/X 方向反転： 

図形が X軸を中心に反転します。（縦方向の反転）／ 図形が Y軸を中心に反転します。（横方向の反転） 

Y 方向反転は、回転と組合せて使用可能ですが、X方向反転は回転と組合せて使用することは出来ません。 

メインメニュー [View]->[Mirror to Y-Axis]、[View]->[Mirror to X-Axis』 

ツールボタン 

 

ショートカットキー（初期値） なし 

d). 情報表示： 

図面上（画面左上）に情報を表示します。（ファイル名、最終編集日時、ストラクチャ名、階層数、回転状態、反転状態）、 

（データ領域の最小座標と最大座標） 

⇒ストラクチャ表示が初期状態から画面のスクロール、拡大・縮小等で変更された場合には、ストラクチャ名のみが表示されます。 

メインメニュー [View]->[Draw Information] 

ツールボタン  

ショートカットキー（初期値） なし 

e). カーソル吸着： 

マウスカーソルを図形の辺に吸着します。（ルーラーの自動モード時やメモ作成時等は吸着しません） 

⇒吸着した図形のレイヤー名を表示します。（図形が重なっている場合には、一番上に表示されているレイヤー名） 

メインメニュー [Tool]->[Snap Cursor to Shape] 

ツールボタン  

ショートカットキー（初期値） なし 

 

 

  



【拡張機能】 

８．ルーラー作成機能 

画面上、任意の座標間の距離を測定します（最大 100 個）。画面の拡大・縮小に係らず、寸法線と寸法表示を維持します。 

表示するストラクチャを変更した場合には、寸法線はリセットされます。 

※画面右上の『Grid(um)』で最小寸法、『Direction』で X/Y Axis(縦横固定)、Diagonal(縦横+45度)、AnyAngle(角度固定無し)を切替可能です。 

a). ルーラーの追加 

メインメニュー [Tool]->[Ruler] 

ツールボタン  

右クリックメニュー 『Ruler』 

ショートカットキー（初期値） K 

上記動作でルーラーが待機状態になります。画面上で、左クリックした点から測長開始し、次に左クリックした点で測長終了となります。 

b). ルーラーの追加（自動モード） 

メインメニュー [Tool]->[AutoRuler] 

ツールボタン  

右クリックメニュー 『AutoRuler』 

ショートカットキー（初期値） H 

マウスカーソル位置を中心にして、表示している図形の幅や間隔を自動的に算出してルーラーを表示します。（水平・垂直・斜め 45°方向） 

※同じレイヤーの図形が接続している場合には、論理演算により図形を合成した後に幅や間隔を算出します。 

※レイヤーリストにてレイヤーが選択されていて、かつ表示状態の場合には、選択されているレイヤーのみが測定対象となります。 

c). ルーラーの削除（全削除） 

メインメニュー [Tool]->[Clear All Ruler] 

ツールボタン  

右クリックメニュー 『Clear All Ruler』 

ショートカットキー（初期値） SHIFT+K 

d). ルーラーの削除（選択削除） 

ルーラー作成を終了し（メニューの[Ruler]チェック OFF、『 』ボタンが押されていない状態）、図面上で削除したいルーラを(マウスカーソル

が手の形になっている状態で)ダブルクリックすると、削除確認のメッセージが表示されます。 

９．階層間移動 

ストラクチャ内で引用されている（階層が 1つ下の）ストラクチャに移動可能です。 

・メイン画面上でダブルクリックすると、ストラクチャがリスト表示されます。ストラクチャを選択すると階層を移動します。 

・画面右上に階層移動前のストラクチャがリストとして表示されます。リストからストラクチャを選択すると階層を戻ることが出来ます。 

  



１０．メモ機能 

画面上の任意の位置にマーカーを配置して、マーカーの数字とリンクしたコメントをメモリストに追加します。マーカー位置、コメントを CSV

ファイルとして保存可能です（最大 200 個）。保存した CSV ファイルを読み込んで、マーカー及びコメントを表示することも可能です。 

※コメントの左側にチェックボックスが表示されます。[確認済み]、あるいは[対策・修正済み]等の識別用に利用して下さい。 

メインメニュー [Tool]->[Memo] 

ツールボタン  

ショートカットキー（初期値） なし 

 

『 ：図形の上にマーカ追加』『 ：選択したマーカ削除』『 ：*.csv ファイルを開く』『 ：メモリストを*.csv に保存』 

・『図形の上にマーカ追加』を押した後、画面上の任意のポイントをクリックするとマーカーが追加され、同時にメモリストにコメントが追加され

ます。コメントはダブルクリックすることで編集可能です。 

・『選択したマーカ削除』ではコメントを 1 つずつ削除します。現状、全てのコメントを一括して削除する機能は実装していません。 

１１．プリセット座標への移動 

プリセット座標情報（最大 20 点）の保存・読込、及び指定座標への移動 

メインメニュー [Tool]->[Move To] 

ツールボタン  

ショートカットキー（初期値） なし 

⇒プリセット座標用のパネルが表示されます。 

 

・X(um)、Y(um)に移動したい座標を入力する、もしくは『Load File…』ボタンで予め保存してある座標情報を読み込みます。 

・入力した座標の右側にある『Move』ボタンで指定した座標に移動します。 

・X(um)、Y(um)に指定された座標情報は、『Save File…』ボタンで保存可能です(*.csv)。 

 



１２．指定座標に移動 

画面右上の X(um)、Y(um)に移動したい座標を入力し、『Move』ボタンを押すと移動します。 

 

１３．比較モード 

2 つのファイルを読み込んでストラクチャの差分を抽出して表示します（差分は最大 32768 個まで表示）。 

※ストラクチャ編集前後のストリームファイルを比較することで、編集した部分を抽出することが出来ます。また、編集していない部分がズレ

ていないことを確認できます。 

①．比較モードに切り替えます。（メイン画面、ストラクチャリストが分割される。） 

メインメニュー [Window]->[Compare Mode] 

ツールボタン  

ショートカットキー（初期値） なし 

この状態で、比較したい 2つのファイルを読み込みます。 

②．画面右側で上下に分割されたストラクチャリストから、比較したいストラクチャを選択します。 

③．画面左のレイヤーリストにて、比較したいレイヤーを切替えます。（表示・非表示の右側に、比較対象レイヤーの“☑”が並んでいる。） 

④．比較を開始します。 

メインメニュー [Tool]->[Compare Excute]->[Simple Compare] 

[Compare and Boolean(< 1000 diff)] 

ツールボタン  

ショートカットキー（初期値） なし 

実際に比較が開始する前に、表示されるメニューから、『Simple Compare（単純比較）』、 

『Compare and Boolean op [< 1000 diff]（比較後にブーリアン演算：但し、差分が１０００以下の場合）』を選択します。 

⑤．比較実行中は進行状況表示のプログレスバー右下に『 』ボタンが表示されます。このボタンにより処理を中断できます。 

⑥．比較結果の差分が 2つのストラクチャ上で点滅します。左側のレイヤーリストにもレイヤー毎の差分（個数）が表示されます。 

  ※差分として２つの数字が表示されます。（ファイル２のストラクチャにあってファイル１のストラクチャに無い図形の個数、およびその逆） 

   比較結果がブーリアン演算されたレイヤーは数字が赤字にて表示され、単純比較のみのレイヤーは数字が黒字にて表示されます。 

⑦．レイヤーリストに表示されている比較結果の差分（個数）をダブルクリックすると、アイテムサーチウィンドウが開きます。 

  ウィンドウ内の上下ボタンを使って、差分が発生している図形を 1つずつ確認することができます。 

  （アイテムサーチウィンドウでは、選択している図形のハイライト有無、表示色、塗りつぶしパターン、及び拡大率を変更できます。） 

 

  



【その他設定】 

a).『Config…』: 

グリッド、テキスト表示の自動スキップ等の表示設定に加えて、フォント設定、ショートカットキーのカスタマイズを行います。 

メインメニュー [Tool]->[Config…] 

[Display Setting] 

 

Display Minimum Size: 

 画面に表示する図形の長辺最小サイズ設定(0.2～1ピクセル)スライダー右端(1ピクセル)が旧バージョン相当)。 

Grid: 

 画面に小グリッド表示する際の間隔(um)、グリッド間隔の画面上しきい値(グリッド間隔が設定ピクセル数以上でグリッド表示)、 

大グリッド表示間隔(小グリッドの個数指定)。 

Display Style: 

 マウスカーソルのスタイル、X/Y軸表示、背景色、ストラクチャの情報表示簡略化設定、 

比較モード時のウィンドウ配置設定。 

Display Skip Text: 

テキストの非表示設定(倍率、背後、重複)。 

Draw Color Setting: 

 各種色設定(グリッド、X/Y軸、ルーラー等)。 

Other: 

 画面の左側と上側に座標確認用定規を表示／マウスドラッグによる図形移動時の領域外表示／ 

 (マウスカーソルが図形の辺に吸着している状態で)マウス左ボタンクリックで該当レイヤー塗り潰し／ 

マウスカーソル吸着強度(ルーラー作成時と通常のカーソル移動時)。 

  



[Font] 

フォント設定 

 

 

[Shortcut Key] 

ショートカットキー設定 

 

 

  



【メインメニュー一覧】 

File 

File Open ファイルを開く 

Recent Files 最近使用したファイル（最大２０）を開き直す 

 ⇒ファイルとテクノロジファイルの組合せを再現する 

SnapShot 画面のハードコピーをクリップボードに保存 

 ⇒原点、グリッド、インフォメーションの表示・非表示、背景白色などが選択可能 

Load Technology File テクノロジファイルを読み込む 

Default TecFileFolder テクノロジファイルの既定フォルダを指定する 

⇒レイヤーリスト下側の『TecFile…』ボタンがコンボボックスに代わり、 

既定フォルダ内のテクノロジファイルがリストアップされる 

Exit GDS2LayoutViewer アプリケーションを終了する 

Layer 

Layer Setup レイヤー設定ダイアログを開く 

Initialize Layer Setting レイヤー設定を初期化する（テクノロジファイル再読込） 

All Layer Visible 全てのレイヤーを表示する 

All Layer Not Visible 全てのレイヤーを非表示にする 

Initialize LayerList Width レイヤーリストの幅を初期化する 

All Layer Compare 全てのレイヤーを比較対象にする 

All Layer Not Compare 全てのレイヤーを比較対象から外す 

Hide LayerList レイヤーリストを隠す 

Structure 

Copy StructureName ストラクチャ名をコピーする 

Copy All StructureName 全てのストラクチャ名をコピーする 

StructureList Sort by ストラクチャリストの並び順を変更する 

[Name（名前順）, Hierarchy（階層の深さ順）, ElementCount（図形要素の総数順）] 

 ⇒規定値は ElementCount(図形要素の総数) 

Initialize StructureList 

Width 

ストラクチャリストの幅を初期化する 

Hide StructureList ストラクチャリストを隠す 

 

 

 

 

 

 

 

 



 

View 

Fit to Screen ウィンドウサイズに合わせて図形を全体表示する 

Zoom In 図形を拡大する 

Zoom Out 図形を縮小する 

Rotate 図形を回転する 

Mirror to X-Axis X軸を中心に図形を回転する 

Mirror to Y-Axis Y軸を中心に図形を回転する 

Draw Information インフォメーションを表示する 

 ⇒ファイル名、最終変更日時、ストラクチャ名、階層、回転、反転、 

図形の最大・最小座標等が表示可能 

Draw SREF Inside SREF内の図形を表示する 

 ⇒表示しない場合には枠線と SREF名が表示される 

Draw Text Data テキストデータを表示する 

Draw Grid グリッドを表示する 

Draw Hatch Brush レイヤー毎に設定したハッチブラシで図形を塗りつぶす 

Draw Aref Inside AREFの内側を表示する 

 ⇒表示しない場合には AREF 最外周のみ表示する 

Bird’s-eye View Window 全体表示ウィンドウ（縮小表示）を表示する 

ToolBar ツールバーを表示する[File, Compare, Tool, View, ON/OFF] 

Redraw 再描画 

Tool 

Ruler ルーラーを作成する 

Auto Ruler ルーラーを作成する（自動モード） 

Clear All Ruler 全てのルーラーを削除する 

Snap Cursor to Shape マウスカーソルを図形の辺に吸着する 

Compare Mode 図形比較モードに切り換える 

Compare Excute 図形を比較する 

[Simple Compare, Compare and Boolean(< 1000 diff), Compare and Boolean(no Limit)] 

Memo メモを作成・表示する 

Move To 指定座標への移動用パネルを表示する 

Config 各種表示設定、フォント設定、ショートカットキー設定 

※ショートカットキーのメニュー項目一覧には、実際には機能しないものも含まれています。 

Help 

About このアプリケーションについて 

 

  



【右クリックメニュー】 

a). ストラクチャの上で右クリックした場合 

File Open… ファイルを開く 

Recent Files ファイル履歴の表示 

Snapshot 画面のスナップショットをコピー 

Fit toScreen ストラクチャを拡大表示 

Ruler ルーラーの作図開始 

Ruler Cancel ルーラーの作図キャンセル 

Clear All Ruler 全てのルーラー削除 

Copy StructureName ストラクチャ名をコピー 

Redraw 再描画 

 

b). 画面左側のレイヤーリスト上で右クリックした場合 

Load Tec… テクノロジファイルの読込み 

Default TecFileFolder… デフォルトのテクノロジファイルフォルダの指定 

Initialize LayerSetting レイヤー設定を初期化 

All Layer Visible 全レイヤーを表示 

All Layer Not Visible 全レイヤーを非表示 

Initialize LayerList 

Width 

レイヤーリストの幅を初期化 

All Layer Compare （比較モード）全てのレイヤーを比較対象に設定 

All Layer Not Compare （比較モード）全てのレイヤーを比較対象から除外 

  

c). 画面右側のストラクチャリスト上で右クリックした場合 

Copy All Name 全てのストラクチャ名をコピー 

Sort by ストラクチャリストの並び替え（名前、階層の深さ、図形要素数） 

Initialize Width ストラクチャリストの幅を初期化 

 

  



【ショートカットキー一覧：初期値】 

 

[CTRL] + [O] ファイルを開く 

[CTRL] + [C] ストラクチャのスナップショットをクリップボードにコピー 

[CTRL] + [(num)+] / [CTRL] + [;] ストラクチャ内のテキストフォントサイズを大きくする 

[CTRL] + [(num)-] / [CTRL] + [-] ストラクチャ内のテキストフォントサイズを小さくする 

[CTRL] + [SHIFT] + [(num)+] /  

[CTRL] + [SHIFT] + [;] 

インフォメーション表示のフォントサイズを大きくする 

[CTRL] + [SHIFT] + [(num)-] /  

[CTRL] + [SHIFT] + [-] 

インフォメーション表示のフォントサイズを小さくする 

[SHIFT] + [(num)+] / [SHIFT] + [;] ルーラーのテキストフォントサイズを大きくする 

[SHIFT] + [(num)-] / [SHIFT] + [-] ルーラーのテキストフォントサイズを小さくする 

[SHIFT] + [V] 全体表示ウィンドウの表示・非表示切替え 

[F] ストラクチャの全体表示 

[(num)+] / [CTRL] + [Z] / 

[CTRL] + [Mouse Wheel Up] 

ストラクチャ表示の拡大（1.25 倍） 

[(num)-] / [SHIFT] + [Z] /  

[CTRL] + [Mouse Wheel Down] 

ストラクチャ表示の縮小（0.8 倍） 

[SHIFT] + [F] 全階層を表示する（最大１０２４階層） 

[CTRL] + [F] 表示階層を０層のみにする(SREF/AREF 内の図形を表示しない) 

[SHIFT] + [B] 階層を１つ上がる（ストラクチャ内の SREF に移動して階層が下がっている場合） 

[CTRL] + [R] ストラクチャの再描画 

[K] ルーラーの作図開始 

[SHIFT] + [K] ルーラーの全消去 

[(num)0] / [0] 表示階層を切り替える（０層/全階層（最大１０２４階層）） 

[(num)1] / [1] 表示階層を１層までにする 

[(num)2] / [2] 表示階層を２層までにする 

[(num)3] / [3] 表示階層を３層までにする 

[(num)4] / [4] 表示階層を４層までにする 

[(num)5] / [5] 表示階層を５層までにする 

[(num)6] / [6] 表示階層を６層までにする 

[(num)7] / [7] 表示階層を７層までにする 

[(num)8] / [8] 表示階層を８層までにする 

[(num)9] / [9] 表示階層を９層までにする 

矢印キー[↑] / [Mouse Wheel Down] ストラクチャ表示を上側に移動 

矢印キー[↓] / [Mouse Wheel Up] ストラクチャ表示を下側に移動 

矢印キー[←] / [SHIFT] + [Mouse Wheel Up] ストラクチャ表示を右側に移動 

矢印キー[→] / [SHIFT] + [Mouse Wheel Down] ストラクチャ表示を左側に移動 

 

  



【設定の初期化】 

GDS2LayoutView 終了時に、GDS2LV.exe と同じフォルダに GDS2LV.ini が作成されます。 

このファイルには、ウィンドウのサイズやファイル履歴などアプリケーションの設定に関する情報が保存されています。 

GDS2LV.ini を削除すると、アプリケーションが初期化されます。 

【サポート】 

  感想、要望、バグ報告などは下記まで連絡下さい。 

gdsreader@gmail.com 

【著作権】 

本ソフトウェアは著作権法及び、国際著作権条約により保護されています。 

使用ユーザは付属ソフトウェア及び付属文書に付された権利表示を除去、改変してはいけません。 

【配布】 

インターネット上での２次配布、紹介等は事前の承諾無く行っても構いません。 

【禁止事項】 

ユーザは以下の事を行う事は出来ません。 

1. オリジナル以外の形で他の人に配布する事 

2. 第三者に対して、本ソフトウェアを販売、販売を目的とした宣伝、使用、営業、複製等を行う事 

3. 第三者に対して、本ソフトウェアの使用権を譲渡または再承諾する事 

4. 本ソフトウェアをリバースエンジニアリング、逆コンパイル、逆アセンブルする事 

5. 本承諾書、付属文書、本ソフトウェアの一部又は全部を改変、除去する事 

【免責事項】 

作者は、本ソフトウェアの使用または使用不能から生じるコンピュータの故障、情報の消失、その他あらゆる直接的及び間接的被害に関

して一切の責任を負いません。また、作者はこのソフトウェアをより良いものとするように最善の努力を行いますが、バグ修正・バージョンア

ップを行う義務を負いません。以上のことに納得できる方のみ、個人の責任においてご使用下さい。 

mailto:gdsreader@gmail.com
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